Bug 985991 - kernels > 3.11.0-0.rc0.git3.1.fc20.x86_64 do not boot properly
kernels > 3.11.0-0.rc0.git3.1.fc20.x86_64 do not boot properly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 13:13 EDT by Nicolas Mailhot
Modified: 2013-08-18 03:37 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-18 03:37:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
working and failing boot logs (121.27 KB, application/x-xz)
2013-07-18 13:14 EDT, Nicolas Mailhot
no flags Details
new failing boot logs (74.85 KB, application/x-xz)
2013-07-27 03:57 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2013-07-18 13:13:28 EDT
kernel 3.11.0-0.rc0.git3.1.fc20.x86_64 is the last working one on my box, the following are broken (no networking, no console after radeonfb + vesafb → radeonfb handover, wrong resolution in X, and probably others I didn't bother to identify)

The same system (no package changes) boots properly with 3.11.0-0.rc0.git3.1.fc20.x86_64
Comment 1 Nicolas Mailhot 2013-07-18 13:14:21 EDT
Created attachment 775384 [details]
working and failing boot logs
Comment 2 Yanko Kaneti 2013-07-19 04:01:44 EDT
Most things radeon would not work properly until linux-firmware is updated with the latest blobs from amd. I'd wait for that and retest the newer rc kernels then.
Comment 3 Nicolas Mailhot 2013-07-27 03:56:46 EDT
And now X & console finally work, but networking is still hosed
Comment 4 Nicolas Mailhot 2013-07-27 03:57:25 EDT
Created attachment 778986 [details]
new failing boot logs
Comment 5 Marian Csontos 2013-07-29 09:16:45 EDT
Have seen "something-like-that" as well. I laboured a while with network to realize it is kernel related.

One symptom of broken network was that IPv6 though disabled in ifcfg-eth0 (and later in sysctl too) was used for connections.

Booting into older kernel and updating to 3.11.0-0.rc2.git3.1.fc20.x86_64 (with disabled IPv6) worked for me :-)
Comment 6 Jirka Klimes 2013-07-30 04:11:37 EDT
Nicolas, if the problem is affected by the kernel, it is most probably the kernel issue, not NM. However, I am not able to open the logs.
Could include /var/log/messsages and dmesg output if you still experience problems?
Comment 7 Nicolas Mailhot 2013-08-18 03:37:30 EDT
sorry, I was away some time

Today (after the mass rebuild and a few kernel update) things seem to work again

(and the attached logs open fine in fire-roller, maybe you're missing and xz handler?)

Thanks for your time

Note You need to log in before you can comment on or make changes to this bug.