Bug 986085 - [abrt] man-db-2.6.3-6.fc19: main: Process /usr/bin/man was killed by signal 6 (SIGABRT)
[abrt] man-db-2.6.3-6.fc19: main: Process /usr/bin/man was killed by signal 6...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Schiffer
Fedora Extras Quality Assurance
abrt_hash:1d6b5b9a475e6150ca32412b447...
:
: 989262 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 19:16 EDT by Christian Stadelmann
Modified: 2013-09-27 20:24 EDT (History)
7 users (show)

See Also:
Fixed In Version: man-db-2.6.3-7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 20:24:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (5.27 KB, text/plain)
2013-07-18 19:16 EDT, Christian Stadelmann
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-18 19:17 EDT, Christian Stadelmann
no flags Details
File: core_backtrace (600 bytes, text/plain)
2013-07-18 19:17 EDT, Christian Stadelmann
no flags Details
File: dso_list (1.00 KB, text/plain)
2013-07-18 19:17 EDT, Christian Stadelmann
no flags Details
File: environ (4.35 KB, text/plain)
2013-07-18 19:17 EDT, Christian Stadelmann
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-18 19:17 EDT, Christian Stadelmann
no flags Details
File: maps (4.25 KB, text/plain)
2013-07-18 19:17 EDT, Christian Stadelmann
no flags Details
File: open_fds (138 bytes, text/plain)
2013-07-18 19:17 EDT, Christian Stadelmann
no flags Details
File: proc_pid_status (928 bytes, text/plain)
2013-07-18 19:17 EDT, Christian Stadelmann
no flags Details
File: var_log_messages (9.67 KB, text/plain)
2013-07-18 19:17 EDT, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2013-07-18 19:16:54 EDT
Description of problem:
I started man with option -M, possibly with an invalid path. I tried different paths for
man -M /path/to/man/pages appname
but all of them fail with a crash. If the given path was invalid, man should at least fail gracefully and give the user a hint.

Version-Release number of selected component:
man-db-2.6.3-6.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        man -M /usr/avr/share/man 3 sleep
crash_function: main
executable:     /usr/bin/man
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (0 frames)

Potential duplicate: bug 716312
Comment 1 Christian Stadelmann 2013-07-18 19:16:58 EDT
Created attachment 775555 [details]
File: backtrace
Comment 2 Christian Stadelmann 2013-07-18 19:17:01 EDT
Created attachment 775556 [details]
File: cgroup
Comment 3 Christian Stadelmann 2013-07-18 19:17:05 EDT
Created attachment 775557 [details]
File: core_backtrace
Comment 4 Christian Stadelmann 2013-07-18 19:17:08 EDT
Created attachment 775558 [details]
File: dso_list
Comment 5 Christian Stadelmann 2013-07-18 19:17:12 EDT
Created attachment 775559 [details]
File: environ
Comment 6 Christian Stadelmann 2013-07-18 19:17:15 EDT
Created attachment 775560 [details]
File: limits
Comment 7 Christian Stadelmann 2013-07-18 19:17:19 EDT
Created attachment 775561 [details]
File: maps
Comment 8 Christian Stadelmann 2013-07-18 19:17:22 EDT
Created attachment 775562 [details]
File: open_fds
Comment 9 Christian Stadelmann 2013-07-18 19:17:25 EDT
Created attachment 775563 [details]
File: proc_pid_status
Comment 10 Christian Stadelmann 2013-07-18 19:17:29 EDT
Created attachment 775564 [details]
File: var_log_messages
Comment 11 Ralf Corsepius 2013-08-17 00:41:52 EDT
Steps to reproduce:

mkdir -p tmp/man
cd man
man -M man foo


reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        man -M man foo
crash_function: main
executable:     /usr/bin/man
kernel:         3.10.5-201.fc19.x86_64
package:        man-db-2.6.3-6.fc19
reason:         Process /usr/bin/man was killed by signal 6 (SIGABRT)
runlevel:       N 5
uid:            1015
Comment 12 Colin Watson 2013-08-17 05:55:38 EDT
This was fixed in man-db 2.6.4-1 by removing an incorrect change from a Fedora patch (man-db-2.6.3-valgrind.patch).
Comment 13 Peter Schiffer 2013-08-19 06:30:59 EDT
I'm sorry for delay, I'll do an update of man-db soon.
Comment 14 Ralf Corsepius 2013-09-17 23:17:44 EDT
(In reply to Peter Schiffer from comment #13)
> I'm sorry for delay, I'll do an update of man-db soon.

Another month has passed and this bug is still unfixed in f19.
Comment 15 ILMostro 2013-09-21 10:38:11 EDT
yup...confirmed as of today, man-db *still* not updated; @version 2.6.3-6.fc19
Comment 16 Ralf Corsepius 2013-09-21 23:04:43 EDT
Peter?
Comment 17 Peter Schiffer 2013-09-23 17:26:20 EDT
Ah, thanks for the ping, I've been too busy lately. I'll do an update tomorrow.
Comment 18 Peter Schiffer 2013-09-24 10:36:32 EDT
*** Bug 989262 has been marked as a duplicate of this bug. ***
Comment 19 Fedora Update System 2013-09-24 12:43:29 EDT
man-db-2.6.3-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/man-db-2.6.3-7.fc19
Comment 20 Fedora Update System 2013-09-26 02:29:13 EDT
Package man-db-2.6.3-7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-db-2.6.3-7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17669/man-db-2.6.3-7.fc19
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2013-09-27 20:24:01 EDT
man-db-2.6.3-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.