Bug 986142 - "Unsupported file format" error message should be shown when the uploading file is not supported by the project-type
"Unsupported file format" error message should be shown when the uploading fi...
Status: CLOSED WORKSFORME
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: zanata-dev-internal
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 00:32 EDT by Ding-Yi Chen
Modified: 2014-03-06 00:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-06 00:38:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-07-19 00:32:27 EDT
Description of problem:
Zanata should show an error messages such as:
"File upload failed because the file format is not supported." 
If the project-type does not support the file format of the uploading file.

This is especially for File projects, as users may assume that .doc (supported by LibreOffice) and upload it, while the backend does not actuall support.


Version-Release number of selected component (if applicable):
Zanata version 3.0.0-alpha-2-SNAPSHOT (20130719-1235)

How reproducible:
Always

Steps to Reproduce:
1. Create a project and version with File project-type.
2. Upload a .doc file as source

Actual results:
Zanata Load the home page and showed:
  Current Errors:
     Unexpected error. Please try again. [ Request: ? ] 

Expected results:
On current page:
  Zanata shows the error message:
    "File upload failed because the file format is not supported."


Additional info:
Comment 1 Damian Jansen 2014-03-06 00:38:03 EST
"Unrecognized file extension for Picture_1.doc."

Note You need to log in before you can comment on or make changes to this bug.