Bug 986161 - When loading an xsd schema, receive "Schemas parser error : local complex type: The content model is not determinist" error
When loading an xsd schema, receive "Schemas parser error : local complex typ...
Status: CLOSED DUPLICATE of bug 922450
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libxml2 (Show other bugs)
5.9
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Daniel Veillard
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 01:51 EDT by Grant Schoep
Modified: 2013-07-22 09:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 09:02:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
And example xsd file to use with /usr/bin/xmllint to demo the problem (348 bytes, application/xml)
2013-07-19 01:51 EDT, Grant Schoep
no flags Details

  None (edit)
Description Grant Schoep 2013-07-19 01:51:31 EDT
Created attachment 775639 [details]
And example xsd file to use with /usr/bin/xmllint to demo the problem

When loading a xsd file for xml validation, I received the following message to STDERR.

example.xsd:4: element complexType: Schemas parser error : local complex type: The content model is not determinist.
WXS schema example.xsd failed to compile

NOTE: "example.xsd" file is the name of my xsd file I am using.

In the most recent RPM update to libxml2,  I've encountered a new problem which I believe is a regression. RPM info I am using...

rpm(cur)  : libxml2-2.6.26-2.1.21.el5_9.2
from      : https://rhn.redhat.com/errata/RHBA-2013-0591.html
rel. date : 2013-03-05

If I downgrade to libxml2-2.6.26-2.1.21.el5_9.1 the problem goes away.

I was seeing this in my libxml2 code, but can reproduce it with rpm provided /usr/bin/xmllint

I can reproduce this with a stripped down xsd file, see attached xsd file.

To reproduce, just run 
/usr/bin/xmllint --schema bad.xsd somefile.xml

You can have somefile.xml just be an empty file, the contents are unimportant. The error happens when it is trying to process the xsd file.

I see this on all RHEL 5.9 Server/Workstation machines that have the latest libxml2 RPM

libxml2-2.6.26-2.1.21.el5_9.2

For our critical operation machines, I had to downgrade to 

libxml2-2.6.26-2.1.21.el5_9.1
Comment 1 Daniel Veillard 2013-07-19 02:32:30 EDT
I think it is a duplicate of
https://bugzilla.redhat.com/show_bug.cgi?id=922450

could you double check with the provided tests rpms at
ftp://xmlsoft.org/libxml2/test/

fix the issue you are seeing ?

  thanks,

Daniel
Comment 2 Grant Schoep 2013-07-20 21:53:30 EDT
I don't have access to see the other bug. But, yes, I tried the rpm (libxml2-2.6.26-2.1.24.x86_64.rpm) from the link and it does fix the problem.

Thanks for the fix Daniel

-grant
Comment 3 Daniel Veillard 2013-07-22 09:02:37 EDT
okidoc, it's a duplicate then !

  thanks for reporting back !

Daniel

*** This bug has been marked as a duplicate of bug 922450 ***

Note You need to log in before you can comment on or make changes to this bug.