Bug 986162 - Metadata locks, data locks in replicate should be in different domains
Metadata locks, data locks in replicate should be in different domains
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Pranith Kumar K
spandura
:
Depends On: 983362
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 01:53 EDT by Pranith Kumar K
Modified: 2013-09-23 18:35 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 983362
Environment:
Last Closed: 2013-09-23 18:35:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2013-07-19 01:53:26 EDT
+++ This bug was initially created as a clone of Bug #983362 +++

Description of problem:

Ranges of data full file lock and meta-data lock overlap because
    of which metadata transactions wait for data transactions to
    unlock inodelk which are causing un-necessary delays

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2013-07-11 01:27:55 EDT ---

REVIEW: http://review.gluster.org/5315 (cluster/afr: Metadata locks are orthogonal to data locks) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2013-07-11 06:15:15 EDT ---

REVIEW: http://review.gluster.org/5315 (cluster/afr: Metadata locks are orthogonal to data locks) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2013-07-12 08:15:03 EDT ---

REVIEW: http://review.gluster.org/5315 (cluster/afr: Metadata locks are orthogonal to data locks) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 spandura 2013-08-22 05:13:07 EDT
Please provide a test case to verify this bug.
Comment 4 Pranith Kumar K 2013-08-22 07:43:13 EDT
When untar of a tar file is done without this fix, it takes one second to untar each file however small. So If we untar linux kernel tree, every file in the tar file used to take 1 second to be untarred.
Comment 6 spandura 2013-08-26 08:28:29 EDT
Verified the fix on the build : 
==================================
glusterfs 3.4.0.22rhs built on Aug 23 2013 01:58:42

Test Case executed on the following builds:
===========================================
Issue Observed build : glusterfs 3.4.0.15rhs built on Aug  5 2013 05:24:33 
Issue Verification build : glusterfs 3.4.0.22rhs built on Aug 23 2013 01:58:42

Test Case:-
==========
1. Create a replicate, distribute-replicate volume. Start the volumes. 

2. Create fuse, nfs mounts for both replicate, distribute-replicate volume. 

3. From mount point untar "tar.gz" file containing 5 files on fuse,nfs mounts. 

4. Note the "real time" taken to untar. 

Expected result: 
===================
Time taken to untar on build "3.4.0.22" is lesser to time taken to untar on build "3.4.0.15"

Actual Result:
===================

1 X 2 Replicate volume : Fuse mount
------------------------------------------------
	        run1	    run2	run3
------------------------------------------------
3.4.0.22    	m0.221s     m0.218s	m0.236s
3.4.0.15   	m8.28s	    m6.399s	m7.294s


2 X 2 Distribute-Replicate volume : Fuse mount
------------------------------------------------
	        run1	    run2	run3
------------------------------------------------
3.4.0.22	m0.213s	    m0.201s	m0.192s
3.4.0.15	m6.485s	    m6.353s	m7.288s


1 X 2 Replicate volume : NFS mount
------------------------------------------------
	        run1	    run2	run3
------------------------------------------------
3.4.0.22	m0.275s	    m0.24s	m0.24s
3.4.0.15	m3.332s	    m6.311s	m5.306s


2 X 2 Distribute-Replicate volume : NFS mount
------------------------------------------------
	        run1	    run2	run3
------------------------------------------------
3.4.0.22	m0.261s	    m0.261s	m0.243s
3.4.0.15	m4.319s	    m3.316s	m3.332s


Bug is fixed. Moving the bug to verified state.
Comment 7 Scott Haines 2013-09-23 18:35:55 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.