Bug 98632 - CD burning system freeze
CD burning system freeze
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: cdrtools (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-06 01:33 EDT by Gian Paolo Mureddu
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-06 03:50:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2003-07-06 01:33:36 EDT
Description of problem:
When upgrading kernel (for the athlon architecture) from the boxed one
(2.4.20-8) to the 2.4.20-13.9  or 2.4.20-18.9 when ereasing or burning a CD-RW
just half the way fixating the disk, the system will freeze. There is also the
case in RHL 7.3 with kernel 2.4.20-13.7, but fixed with a recent cdrtools
package + glibc upgrade to 2.3 and gcc 3.2 upgrade. The problem must be cdrtools
related, because even with a vanilla kernel compiled in the system (using Red
Hat supplied kernel options as guidelines) the problem will happen. The kernel
has as boot parameters hd[*]=ide-scsi. Maybe a fautly ide-scsi driver in 2.4.2x
releases?

Version-Release number of selected component (if applicable):
Default, installed version. Upgrading to 2.00.3-1 won't fix the problem.

How reproducible:
Highly.

Steps to Reproduce:
1. In a fresh install of Red Hat Linux 9 do a full up2date of the system.
2. Burning a CD with either X-CDRoast or Gtoaster will freeze the system when
fixating the disk
3. Hard reboot required to get the system back.
    
Actual results:
System freeze, only with CD-RW

Expected results:


Additional info:
This problem happened with supplied X-CDRoast and Gtoaster, and after installing
latest version of X-CDRoast for Red Hat 9 (and 7.3) and cdrtools, with or
without enabling non-root burning capabilities. Only observed in Athlon compiled
kernel/cdrtools systems.
Comment 1 Harald Hoyer 2003-07-07 04:16:45 EDT
you may try to leave out the hd[*]=ide-scsi parameter and pass 
dev=/dev/hd[*] to cdrecord. Some reported that this works..
Comment 2 Gian Paolo Mureddu 2003-07-07 19:26:21 EDT
I have tried that, works with Xcdroast, but not with Gtoaster as the later does
not recognize the drives. Also works if I burn from the command line. So this is
indeed a cdrtools bug?
Comment 3 Harald Hoyer 2003-07-08 04:37:23 EDT
I think it is a strange interaction between both..
Comment 4 Gian Paolo Mureddu 2003-07-08 04:46:02 EDT
What I find most strange about this is that it *only* happens whenenever I use a
kernel other than 2.4.20-8 (or 2.4.18-27.7x on RH 7.3), though I could not
explain why upgrading cdrtools and GlibC (with GCC) in 7.3 solved the problem...
Odd. I don't know if anyone else with Intel processors have this problem,
though. All the systems in which I have tested this are:

Athlon XP (1500+, 1800+, 2000+)
RAM 512 DDR 2@266Mhz 1@333Mhz
Chipsets: 2 systems with VIA KT-266 (one laptop, 1500+ CPU; one desktop, 2000+ CPU)
1 system with SiS 735 chipset with 2700 DDR memory.

The laptop is the one with RH 7.3 which is the only one who could survive this,
with kernel 2.4.20-13.7 (haven't tried upgrading that kernel to 2.4.21-18.7, though)
Comment 5 Harald Hoyer 2003-07-08 05:10:19 EDT
you might have a look at #84762
Comment 6 Harald Hoyer 2003-07-08 05:11:34 EDT
and 84160
Comment 7 Harald Hoyer 2004-02-05 10:18:05 EST
any solution found?
Comment 8 Gian Paolo Mureddu 2004-02-05 13:10:48 EST
Yes, upgrading cdrtools proved (in my case) to solve the problem. Also
I found that the same package from Fedora Core 1 can be used (safely?)
on RH 9 systems that exhibit the problem with good results.

Note You need to log in before you can comment on or make changes to this bug.