Bug 986368 - nm-applet vpn pptp configuration is not visible
nm-applet vpn pptp configuration is not visible
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager-pptp (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
: 988179 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 11:07 EDT by Tomasz Chilinski
Modified: 2013-08-01 23:31 EDT (History)
4 users (show)

See Also:
Fixed In Version: NetworkManager-pptp-0.9.8.2-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 23:31:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Chilinski 2013-07-19 11:07:04 EDT
After update NetworkManager-pptp to 0.9.8.2-2.fc19 it's not possible to create new PPTP vlans from nm-applet. After selection of VPN type in connection wizard only vpnc, openconnect and openvpn subtypes are visible.
Here are my all versions of NetworkManager packages:
NetworkManager-vpnc-0.9.3.997-4.fc19.x86_64
NetworkManager-openvpn-0.9.6.0-2.fc19.x86_64
NetworkManager-glib-0.9.8.2-8.git20130709.fc19.x86_64
NetworkManager-0.9.8.2-8.git20130709.fc19.x86_64
NetworkManager-pptp-0.9.8.2-2.fc19.x86_64
NetworkManager-openconnect-0.9.7.0-2.git20120918.fc19.x86_64
Comment 1 Tomasz Chilinski 2013-07-19 11:22:08 EDT
Here is the contents of /etc/NetworkManager/VPN/nm-pptp-service.name:
[VPN Connection]
name=pptp
service=org.freedesktop.NetworkManager.pptp
program=/usr/libexec/nm-pptp-service

[GNOME]
auth-dialog=/usr/libexec/nm-pptp-auth-dialog
properties=/usr/lib64/NetworkManager/libnm-pptp-properties
supports-external-ui-mode=true

There is no /usr/lib64/NetworkManager/libnm-pptp-properties file.
There are only the following files in this directory:
libnm-openconnect-properties.so
libnm-openvpn-properties.so
libnm-settings-plugin-ifcfg-rh.so
libnm-vpnc-properties.so

It looks like libnm-pptp-properties.so file has been missed during last update?
Comment 2 Tomasz Chilinski 2013-07-19 16:39:56 EDT
I answer for myself: I've found missed file in separated package NetworkManager-pptp-gnome, So I've installed it and my problem has been resolved.
Comment 3 Jirka Klimes 2013-07-24 10:41:07 EDT
The package has been split into general and Gnome specific sub-packages.
Comment 4 Dan Williams 2013-07-25 17:20:07 EDT
*** Bug 988179 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-07-26 04:53:33 EDT
NetworkManager-pptp-0.9.8.2-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/NetworkManager-pptp-0.9.8.2-3.fc19
Comment 6 Fedora Update System 2013-07-26 19:03:52 EDT
Package NetworkManager-pptp-0.9.8.2-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-pptp-0.9.8.2-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13713/NetworkManager-pptp-0.9.8.2-3.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-08-01 23:31:56 EDT
NetworkManager-pptp-0.9.8.2-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.