This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 986407 - [abrt] qemu-system-x86-1.4.2-4.fc19: spice_logv: Process /usr/bin/qemu-system-x86_64 was killed by signal 6 (SIGABRT)
[abrt] qemu-system-x86-1.4.2-4.fc19: spice_logv: Process /usr/bin/qemu-system...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spice (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
abrt_hash:61c06627b767144f92c3ba2434f...
:
: 995835 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 13:07 EDT by Scott Tsai
Modified: 2013-08-31 09:54 EDT (History)
17 users (show)

See Also:
Fixed In Version: spice-0.12.4-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-10 15:58:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (19.44 KB, text/plain)
2013-07-19 13:07 EDT, Scott Tsai
no flags Details
File: cgroup (381 bytes, text/plain)
2013-07-19 13:07 EDT, Scott Tsai
no flags Details
File: core_backtrace (1.36 KB, text/plain)
2013-07-19 13:07 EDT, Scott Tsai
no flags Details
File: dso_list (9.36 KB, text/plain)
2013-07-19 13:08 EDT, Scott Tsai
no flags Details
File: environ (99 bytes, text/plain)
2013-07-19 13:08 EDT, Scott Tsai
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-19 13:08 EDT, Scott Tsai
no flags Details
File: maps (47.35 KB, text/plain)
2013-07-19 13:08 EDT, Scott Tsai
no flags Details
File: open_fds (1.11 KB, text/plain)
2013-07-19 13:08 EDT, Scott Tsai
no flags Details
File: proc_pid_status (932 bytes, text/plain)
2013-07-19 13:08 EDT, Scott Tsai
no flags Details
File: var_log_messages (739 bytes, text/plain)
2013-07-19 13:08 EDT, Scott Tsai
no flags Details

  None (edit)
Description Scott Tsai 2013-07-19 13:07:17 EDT
Description of problem:
virt-manager "viewer" disconnecting from Windows XP guest that's playing audio

Version-Release number of selected component:
qemu-system-x86-1.4.2-4.fc19

Additional info:
reporter:       libreport-2.1.5
.gdb_history:   
backtrace_rating: 4
cmdline:        /usr/bin/qemu-system-x86_64 -machine accel=kvm -name audible -S -machine pc-0.14,accel=kvm,usb=off -m 512 -smp 1,sockets=1,cores=1,threads=1 -uuid 668756fb-86e4-fcb5-5a0f-359b4f58622a -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/audible.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/var/lib/libvirt/images/winxp-audible.img,if=none,id=drive-ide0-0-0,format=raw -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive if=none,id=drive-ide0-1-0,readonly=on,format=raw -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=28,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:26:a6:67,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5901,addr=127.0.0.1,disable-ticketing,seamless-migration=on -vga std -device ES1370,id=sound0,bus=pci.0,addr=0x4 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5
crash_function: spice_logv
executable:     /usr/bin/qemu-system-x86_64
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            107
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 spice_logv at log.c:109
 #3 spice_log at log.c:123
 #4 red_channel_remove_client at red_channel.c:1660
 #5 red_channel_client_disconnect_dummy at red_channel.c:1679
 #6 red_channel_client_disconnect at red_channel.c:1689
 #7 snd_disconnect_channel at snd_worker.c:223
 #8 snd_receive at snd_worker.c:466
 #9 snd_event at snd_worker.c:496
 #10 qemu_iohandler_poll at iohandler.c:159
 #11 main_loop_wait at main-loop.c:417

Potential duplicate: bug 906979
Comment 1 Scott Tsai 2013-07-19 13:07:25 EDT
Created attachment 775866 [details]
File: backtrace
Comment 2 Scott Tsai 2013-07-19 13:07:31 EDT
Created attachment 775867 [details]
File: cgroup
Comment 3 Scott Tsai 2013-07-19 13:07:50 EDT
Created attachment 775868 [details]
File: core_backtrace
Comment 4 Scott Tsai 2013-07-19 13:08:00 EDT
Created attachment 775869 [details]
File: dso_list
Comment 5 Scott Tsai 2013-07-19 13:08:05 EDT
Created attachment 775870 [details]
File: environ
Comment 6 Scott Tsai 2013-07-19 13:08:12 EDT
Created attachment 775871 [details]
File: limits
Comment 7 Scott Tsai 2013-07-19 13:08:19 EDT
Created attachment 775872 [details]
File: maps
Comment 8 Scott Tsai 2013-07-19 13:08:24 EDT
Created attachment 775873 [details]
File: open_fds
Comment 9 Scott Tsai 2013-07-19 13:08:29 EDT
Created attachment 775874 [details]
File: proc_pid_status
Comment 10 Scott Tsai 2013-07-19 13:08:34 EDT
Created attachment 775875 [details]
File: var_log_messages
Comment 11 Hans de Goede 2013-08-02 09:54:36 EDT
This is fixed upstream, updated spice-server packages which include the fixes are on their way.
Comment 12 Fedora Update System 2013-08-02 10:39:27 EDT
spice-0.12.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/spice-0.12.4-1.fc19
Comment 13 Fedora Update System 2013-08-02 17:59:32 EDT
Package spice-0.12.4-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spice-0.12.4-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14110/spice-0.12.4-1.fc19
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-08-06 07:00:45 EDT
spice-0.12.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/spice-0.12.4-1.fc18
Comment 15 Fedora Update System 2013-08-06 19:38:50 EDT
Package spice-0.12.4-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spice-0.12.4-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14362/spice-0.12.4-1.fc18
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-08-10 15:58:53 EDT
spice-0.12.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-08-14 22:58:21 EDT
spice-0.12.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Cole Robinson 2013-08-31 09:54:48 EDT
*** Bug 995835 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.