Bug 986435 - please backport patch for bug 9699 from upstream (SPN case sensitivity)
please backport patch for bug 9699 from upstream (SPN case sensitivity)
Status: CLOSED DUPLICATE of bug 955683
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: samba (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Andreas Schneider
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 15:29 EDT by James Ralston
Modified: 2013-07-22 07:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 07:27:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 9699 None None None Never

  None (edit)
Description James Ralston 2013-07-19 15:29:13 EDT
Description of problem:

Samba release 3.6.14 contains a patch to correct bug 9699, in which the "net ads" command always converts the SPN to uppercase. This breaks using samba to create keytab entries for NFSv4/GSS, as "net ads keytab add nfs" adds "NFS", not "nfs", which fails because rpc.gssd is case-sensitive.

Please backport the patch from bug 9699. Thank you.
Comment 2 James Ralston 2013-07-19 15:36:05 EDT
For samba4, Samba release 4.0.6 contains the same fix for Samba bug 9699, so it would probably be a good idea to backport the fix to the samba4 package, too.

Do you want me to file a separate Bugzilla request for that, or is this comment sufficient?
Comment 3 Andreas Schneider 2013-07-22 07:27:49 EDT

*** This bug has been marked as a duplicate of bug 955683 ***

Note You need to log in before you can comment on or make changes to this bug.