Bug 986489 - [abrt] meld-1.7.3-1.fc19: gtk_tree_model_get_valist: Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
[abrt] meld-1.7.3-1.fc19: gtk_tree_model_get_valist: Process /usr/bin/python2...
Status: CLOSED DUPLICATE of bug 975455
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
abrt_hash:31ce44d152fc566cf2d92104bd9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 18:52 EDT by Alan Schmidt
Modified: 2014-07-02 20:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 20:42:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (41.97 KB, text/plain)
2013-07-19 18:52 EDT, Alan Schmidt
no flags Details
File: cgroup (141 bytes, text/plain)
2013-07-19 18:52 EDT, Alan Schmidt
no flags Details
File: core_backtrace (3.88 KB, text/plain)
2013-07-19 18:52 EDT, Alan Schmidt
no flags Details
File: dso_list (12.24 KB, text/plain)
2013-07-19 18:52 EDT, Alan Schmidt
no flags Details
File: environ (3.85 KB, text/plain)
2013-07-19 18:52 EDT, Alan Schmidt
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-19 18:52 EDT, Alan Schmidt
no flags Details
File: maps (62.89 KB, text/plain)
2013-07-19 18:52 EDT, Alan Schmidt
no flags Details
File: open_fds (1.31 KB, text/plain)
2013-07-19 18:52 EDT, Alan Schmidt
no flags Details
File: proc_pid_status (935 bytes, text/plain)
2013-07-19 18:52 EDT, Alan Schmidt
no flags Details
File: var_log_messages (1.06 KB, text/plain)
2013-07-19 18:52 EDT, Alan Schmidt
no flags Details

  None (edit)
Description Alan Schmidt 2013-07-19 18:52:34 EDT
Description of problem:
Read about Meld in Linux Today. Installed it and launched it.

Clicked on the "Directory Comparison" button for fun. Tried to use the drop-down under the "Direcory Comparison" button to maybe open a dialog for my home directory. Meld died.

Errors on the command line (they say "Warning"--but if they're not a big deal, then the warnings themselves are bugs, warning about things that are nevertheless not big deals):

/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: attempting to add an interface (GtkEditable) to class (HistoryFileEntry) after class_init
  type_register(cls, namespace.get('__gtype_name__'))
/usr/bin/meld:167: GtkWarning: gtk_tree_model_filter_get_value: assertion `GTK_TREE_MODEL_FILTER (model)->priv->stamp == iter->stamp' failed
  gtk.main()
/usr/bin/meld:167: Warning: gtype.c:4239: type id `0' is invalid
  gtk.main()
/usr/bin/meld:167: Warning: can't peek value table for type `<invalid>' which is not currently referenced
  gtk.main()
Segmentation fault (core dumped)

Version-Release number of selected component:
meld-1.7.3-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        python /usr/bin/meld
crash_function: gtk_tree_model_get_valist
executable:     /usr/bin/python2.7
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 gtk_tree_model_get_valist at gtktreemodel.c:1470
 #1 gtk_tree_model_get at gtktreemodel.c:1432
 #2 combo_box_row_separator_func at gtkfilechooserbutton.c:2365
 #3 tree_column_row_is_sensitive at gtkcombobox.c:1904
 #4 gtk_combo_box_list_button_released at gtkcombobox.c:4160
 #5 _gtk_marshal_BOOLEAN__BOXED at gtkmarshalers.c:86
 #10 gtk_widget_event_internal at gtkwidget.c:5017
 #11 gtk_widget_event at gtkwidget.c:4814
 #12 gtk_propagate_event at gtkmain.c:2490
 #13 gtk_main_do_event at gtkmain.c:1685

Potential duplicate: bug 975454
Comment 1 Alan Schmidt 2013-07-19 18:52:38 EDT
Created attachment 776002 [details]
File: backtrace
Comment 2 Alan Schmidt 2013-07-19 18:52:40 EDT
Created attachment 776003 [details]
File: cgroup
Comment 3 Alan Schmidt 2013-07-19 18:52:43 EDT
Created attachment 776004 [details]
File: core_backtrace
Comment 4 Alan Schmidt 2013-07-19 18:52:45 EDT
Created attachment 776005 [details]
File: dso_list
Comment 5 Alan Schmidt 2013-07-19 18:52:48 EDT
Created attachment 776006 [details]
File: environ
Comment 6 Alan Schmidt 2013-07-19 18:52:50 EDT
Created attachment 776007 [details]
File: limits
Comment 7 Alan Schmidt 2013-07-19 18:52:52 EDT
Created attachment 776008 [details]
File: maps
Comment 8 Alan Schmidt 2013-07-19 18:52:55 EDT
Created attachment 776009 [details]
File: open_fds
Comment 9 Alan Schmidt 2013-07-19 18:52:57 EDT
Created attachment 776010 [details]
File: proc_pid_status
Comment 10 Alan Schmidt 2013-07-19 18:52:59 EDT
Created attachment 776011 [details]
File: var_log_messages
Comment 11 Herman M. Hofman 2013-10-01 05:54:04 EDT
This problem stil exists. 
I can't file a new Report automatically because a report (this one) was allready filed. 
Can I bump this? 
Is this becase Meld is a GNome package which we use in KDE? 

Please do fix this. It is so anoying. 

Configuration: 
OS:  Linux 3.11.1-200.fc19.x86_64 x86_64
Systeem:  Fedora release 19 (Schrödinger’s Cat)
KDE:  4.11.1 (NL_nl - Dutch)
Meld: 1.8.1-fc19

$ meld
/usr/bin/meld:167: GtkWarning: gtk_tree_model_filter_get_value: assertion `GTK_TREE_MODEL_FILTER (model)->priv->stamp == iter->stamp' failed
  gtk.main()
/usr/bin/meld:167: Warning: gtype.c:4239: type id `0' is invalid
  gtk.main()
/usr/bin/meld:167: Warning: can't peek value table for type `<invalid>' which is not currently referenced                                                    
  gtk.main()                                                                                                                                                 
Segmentatiefout (geheugendump gemaakt)
Comment 12 Dominic Hopf 2014-07-02 20:42:00 EDT

*** This bug has been marked as a duplicate of bug 975455 ***

Note You need to log in before you can comment on or make changes to this bug.