This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 986538 - Unable to load wifi on Lenovo Thinkpad t431s - Intel Corporation Centrino Advanced-N 6235
Unable to load wifi on Lenovo Thinkpad t431s - Intel Corporation Centrino Adv...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-20 07:37 EDT by Karel Rozhon
Modified: 2013-07-23 23:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-3.9.11-200.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 23:46:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of some commands to provide more info about my hw (1.83 KB, text/plain)
2013-07-20 07:37 EDT, Karel Rozhon
no flags Details
dmesg (61.14 KB, text/plain)
2013-07-20 12:54 EDT, Karel Rozhon
no flags Details
dmesg after modprobe iwlwifi (63.41 KB, text/plain)
2013-07-22 08:52 EDT, Karel Rozhon
no flags Details

  None (edit)
Description Karel Rozhon 2013-07-20 07:37:54 EDT
Created attachment 776132 [details]
output of some commands to provide more info about my hw

Description of problem:
on my Lenovo thinkpad t431s does not work wifi. I have actual version of this module - iwl6000g2b-firmware - md5sum is correct.

Version-Release number of selected component (if applicable):
iwl6000g2b-firmware

Additional info:
more info is in included file
Comment 1 John W. Linville 2013-07-20 12:25:25 EDT
We probably need to see the output from running 'dmesg' shortly after a reboot.
Comment 2 Karel Rozhon 2013-07-20 12:54:14 EDT
Created attachment 776194 [details]
dmesg

OK, there is output of this command. It is from actual liveCD with gnome, directly after boot of OS.
Comment 3 Stanislaw Gruszka 2013-07-22 05:40:10 EDT
There is no messages about iwlwifi, that module is not loaded. Either it is blacklisted or udev does not load it automatically. What happen if you do "modprobe iwlwifi" .
Comment 4 Karel Rozhon 2013-07-22 08:52:08 EDT
Created attachment 776892 [details]
dmesg after modprobe iwlwifi

so I did it. modprobe iwlwifi has no output, but wifi still don't work. In attachement is added new dmesg output after this command, just for sure. 

I just did some google research for this problem and I find out, that on Ubuntu was something, what seems very similar. There is some patch, but it is in .deb and I am not sure if it can be used on rpm based system, in some way. http://askubuntu.com/questions/295027/lenovo-t431s-and-and-wireless-dont-play-nicely
Comment 5 Karel Rozhon 2013-07-22 09:05:58 EDT
I also tried (after modprobe command) grep some info from logs.
pwd = /var/log

grep -ir iwl - no output

[root@localhost log]# grep -ir wifi
messages:Jul 22 08:41:15 localhost NetworkManager[715]: <info> WiFi hardware radio set enabled
messages:Jul 22 08:41:15 localhost NetworkManager[715]: <info> WiFi enabled by radio killswitch; enabled by state file
messages:Jul 22 08:41:19 localhost NetworkManager[715]: <info>   domain search 'wifi.nat.'
messages:Jul 22 08:42:44 localhost kernel: [  101.972836] Intel(R) Wireless WiFi driver for Linux, in-tree:d
Binary file journal/7725dfc225d14958a625ddaaaea5962b/system.journal matches

I looked into BIOS and it seems, that everything connected with wifi shoud be enabled. I also tried use fn + other keys, but with no effect.
Comment 6 Stanislaw Gruszka 2013-07-22 10:17:35 EDT
Just realized that this patch is missed on 3.9 and it most like fix this issue
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=20ecf9fd3bebc4147e2996c08a75d6f0229b90df

It is already on 3.10. Josh please apply it on 3.9 kernels as fix for this bug.
Comment 7 Josh Boyer 2013-07-22 14:51:54 EDT
F19 is rebased to 3.10 now, just not built yet.

I've applied the patch to F18.
Comment 8 Fedora Update System 2013-07-22 20:11:18 EDT
kernel-3.9.11-200.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.9.11-200.fc18
Comment 9 Fedora Update System 2013-07-23 23:46:30 EDT
kernel-3.9.11-200.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.