Bug 986549 - debuginfo conflict with mysql-debuginfo
debuginfo conflict with mysql-debuginfo
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: mariadb (Show other bugs)
19
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-20 09:52 EDT by Germano Massullo
Modified: 2013-07-22 08:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 08:03:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
konsole output (14.27 KB, text/plain)
2013-07-20 09:52 EDT, Germano Massullo
no flags Details

  None (edit)
Description Germano Massullo 2013-07-20 09:52:11 EDT
Created attachment 776171 [details]
konsole output

Description of problem:
My machine is a F19 upgraded from F18. The migration from mysql to mariadb left some troubles behind... I was installing debuginfos for an Amarok crash, when I noticed a conflict between mysql-debuginfo and mariadb-debuginfo packages. I solved by removing mysql-debuginfo.
It should be scheduled that the migration to mariadb removes all mysql debuginfos.
Comment 1 Honza Horak 2013-07-22 04:40:16 EDT
Thanks for reporting, but I'm not sure if we can do much about that. It doesn't seem easy to generate the same provides/obsoletes with debuginfo as with other subpackages, if it's possible at all.

What's more, it's probably not what we want -- we don't want to update debuginfo package to mariadb-debuginfo automatically when someone had mysql-debuginfo installed, since debuginfo packages are generally not strictly tied to packages actually installed on the computer.

But even if we wanted, it is probably not worth the trouble.
Comment 2 Germano Massullo 2013-07-22 05:38:53 EDT
Ok, thank you for the explanation
Comment 3 Honza Horak 2013-07-22 08:03:25 EDT
Always welcome. So I'll close this for now as per comment #1, feel free to re-open if necessary.

Note You need to log in before you can comment on or make changes to this bug.