Bug 986593 - Maven repo: Incorrect versions in POM files
Maven repo: Incorrect versions in POM files
Status: VERIFIED
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal Packaging (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium
: ER04
: 6.1.0
Assigned To: Jean-frederic Clere
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-20 17:04 EDT by Miroslav Cupák
Modified: 2018-02-06 14:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Cupák 2013-07-20 17:04:03 EDT
Description of problem:
gatein-dep-1.2.1.Final-redhat-1.pom uses variables to specify versions of dependencies. Some of these variables are not defined anywhere in the file or its parent.


Additional info:
List of problems:
[ERROR] 'dependencies.dependency.version' for javax.enterprise:cdi-api:jar must be a valid version but is '${version.cdi.spec}'. @ line 30, column 13
[ERROR] 'dependencies.dependency.version' for jgroups:jgroups:jar must be a valid version but is '${org.jgroups.version}'. @ line 123, column 13
Comment 2 hfnukal@redhat.com 2013-08-22 07:06:47 EDT
Fixed in gatein-dep-1.2.1.Final-redhat-2.pom

Note You need to log in before you can comment on or make changes to this bug.