Bug 986602 - [abrt] kdelibs-4.10.90-1.fc20: raise: Process /usr/bin/kde4-config was killed by signal 6 (SIGABRT)
[abrt] kdelibs-4.10.90-1.fc20: raise: Process /usr/bin/kde4-config was killed...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:9e065ae495f69ad63960e5b7980...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-20 17:35 EDT by Martin Bříza
Modified: 2013-07-20 18:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-20 18:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.57 KB, text/plain)
2013-07-20 17:35 EDT, Martin Bříza
no flags Details
File: cgroup (158 bytes, text/plain)
2013-07-20 17:35 EDT, Martin Bříza
no flags Details
File: core_backtrace (1.71 KB, text/plain)
2013-07-20 17:35 EDT, Martin Bříza
no flags Details
File: dso_list (4.75 KB, text/plain)
2013-07-20 17:35 EDT, Martin Bříza
no flags Details
File: environ (3.79 KB, text/plain)
2013-07-20 17:35 EDT, Martin Bříza
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-20 17:35 EDT, Martin Bříza
no flags Details
File: maps (29.15 KB, text/plain)
2013-07-20 17:35 EDT, Martin Bříza
no flags Details
File: open_fds (134 bytes, text/plain)
2013-07-20 17:35 EDT, Martin Bříza
no flags Details
File: proc_pid_status (933 bytes, text/plain)
2013-07-20 17:35 EDT, Martin Bříza
no flags Details
File: xsession_errors (1.51 MB, application/octet-stream)
2013-07-20 17:36 EDT, Martin Bříza
no flags Details

  None (edit)
Description Martin Bříza 2013-07-20 17:35:09 EDT
Description of problem:
su -c 'mkdir /opt/gsoc13_qt4; chown mbriza /opt/gsoc13_qt4'
git clone kde:polkit-qt-1
cd polkit-qt-1
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/opt/gsoc13_qt4 ..
make && make install
cd ../..
git clone kde:polkit-kde-agent-1
cd polkit-kde-agent-1
mkdir build
cd build
export PATH=/opt/gsoc13_qt4:$PATH
cmake -DCMAKE_INSTALL_PREFIX ..
<crash>

Version-Release number of selected component:
kdelibs-4.10.90-1.fc20

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 3
cmdline:        /usr/bin/kde4-config --path data
crash_function: raise
executable:     /usr/bin/kde4-config
kernel:         3.9.8-300.fc19.x86_64
runlevel:       unknown
uid:            1000
var_log_messages: Jul  9 21:55:45 localhost abrt[6554]: Saved core dump of pid 6553 (/usr/bin/kde4-config) to /var/tmp/abrt/ccpp-2013-07-09-21:55:45-6553 (2347008 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 realloc at /lib64/libc.so.6
 #5 QListData::realloc(int) at /opt/gsoc13/lib/libQt5Core.so.5
 #6 QListData::append(int) at /opt/gsoc13/lib/libQt5Core.so.5
 #7 QList<QResourceRoot*>::append(QResourceRoot* const&) at /opt/gsoc13/lib/libQt5Core.so.5
 #8 qRegisterResourceData(int, unsigned char const*, unsigned char const*, unsigned char const*) at /opt/gsoc13/lib/libQt5Core.so.5
 #9 _GLOBAL__sub_I_qrc_mimetypes.cpp at /opt/gsoc13/lib/libQt5Core.so.5
 #10 call_init.part.0 at /lib64/ld-linux-x86-64.so.2
 #11 _dl_init_internal at /lib64/ld-linux-x86-64.so.2
 #12 _dl_start_user at /lib64/ld-linux-x86-64.so.2
 #13 ??
Comment 1 Martin Bříza 2013-07-20 17:35:14 EDT
Created attachment 776284 [details]
File: backtrace
Comment 2 Martin Bříza 2013-07-20 17:35:18 EDT
Created attachment 776285 [details]
File: cgroup
Comment 3 Martin Bříza 2013-07-20 17:35:21 EDT
Created attachment 776286 [details]
File: core_backtrace
Comment 4 Martin Bříza 2013-07-20 17:35:25 EDT
Created attachment 776287 [details]
File: dso_list
Comment 5 Martin Bříza 2013-07-20 17:35:29 EDT
Created attachment 776288 [details]
File: environ
Comment 6 Martin Bříza 2013-07-20 17:35:35 EDT
Created attachment 776289 [details]
File: limits
Comment 7 Martin Bříza 2013-07-20 17:35:39 EDT
Created attachment 776290 [details]
File: maps
Comment 8 Martin Bříza 2013-07-20 17:35:43 EDT
Created attachment 776291 [details]
File: open_fds
Comment 9 Martin Bříza 2013-07-20 17:35:47 EDT
Created attachment 776292 [details]
File: proc_pid_status
Comment 10 Martin Bříza 2013-07-20 17:36:07 EDT
Created attachment 776293 [details]
File: xsession_errors
Comment 11 Martin Bříza 2013-07-20 17:39:27 EDT
The cmake prefix in the last command was of course valid, I just wrote the commands from the top of my mind...
Comment 12 Rex Dieter 2013-07-20 18:13:27 EDT
I see a Qt5 in that backtrace, I don't think it's safe to mix-n-match qt4/qt5 like this.
Comment 13 Kevin Kofler 2013-07-20 18:14:50 EDT
Huh?

> #5 QListData::realloc(int) at /opt/gsoc13/lib/libQt5Core.so.5
in kde4-config?

That looks like a bad LD_PRELOAD to me.
Comment 14 Martin Bříza 2013-07-20 18:15:31 EDT
yeah, notabug, it's qt5 master anyway

Note You need to log in before you can comment on or make changes to this bug.