Bug 986621 - Very long login delay at first login.
Very long login delay at first login.
Status: CLOSED DUPLICATE of bug 972881
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-20 23:41 EDT by Neil
Modified: 2014-01-12 19:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-02 13:45:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
thegame (1.40 MB, image/png)
2013-07-20 23:41 EDT, Neil
no flags Details

  None (edit)
Description Neil 2013-07-20 23:41:43 EDT
Created attachment 776347 [details]
thegame

Description of problem:

I just made a clean install (netinstall) of Fedora 19 and I have to wait over 2 minutes after login to use my MATE, nothing start, panel, caja, nothing (pic related), at first I think that it was a Mate-session bug, I opted for make various new separate netinstalling with lightweight desktops; Openbox and XFCE, XFCE and Openbox doesn't have this problem, after some weeks on XFCE I installed a new clean netinstall with Cinnamon, but the login problem was there too, I go back to my MATE environment and after boot it didn't logged in lightdm, I Ctrl + Alt + F2, and logged in tty2 but guess what, I needed to wait not 2 minutes, just 1, after look top, and see that there was no Mate process, I can think that its not a Mate problem... so? how I can fix it?
Comment 1 michael.prisant 2013-08-02 11:40:37 EDT
This annoying bug may be related to: https://bugzilla.redhat.com/show_bug.cgi?id=708866

This error message appeared in my logs: 

dbus-daemon: [system] Failed to activate service 'org.freedesktop.ConsoleKit': timed out

In my case, applying the fix suggested for 708866 (as root or with sudo):

# systemctl enable console-kit-daemon.service

resolved the long delay on first login.
Comment 2 Wolfgang Ulbrich 2013-08-02 13:45:00 EDT
This issue is related to a known selinux/consolekit issue.
see https://bugzilla.redhat.com/show_bug.cgi?id=972881
See my comment 49.
Uninstall all consolekit packages should fix the issue.
You should also update to mate-power-manager-1.6.2-1.fc19 from updates-testing to do not run in the 'suspend on lid close' issue.
We will remove consolekit from Mate's comps group soon.

*** This bug has been marked as a duplicate of bug 972881 ***
Comment 3 Neil 2013-08-02 14:59:39 EDT
yup, it worked, thanks.

Note You need to log in before you can comment on or make changes to this bug.