Bug 986680 - cinder: cannot use wild card in cinder list --display-name
cinder: cannot use wild card in cinder list --display-name
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: ---
: 5.0 (RHEL 7)
Assigned To: Eric Harney
Haim
storage
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 10:36 EDT by Dafna Ron
Modified: 2016-04-26 15:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Wildcards are now supported in Block Storage (cinder) for resource searches. For example, users can now use wildcards in the 'cinder list --display-name' or the 'cinder snapshot-list --display-name' commands.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 02:52:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1262604 None None None Never

  None (edit)
Description Dafna Ron 2013-07-21 10:36:45 EDT
Description of problem:

I tried using --display-name in cinder list and output is empty. 

example, I have several volumes: 
[root@opens-vdsb ~(keystone_admin)]# cinder list
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
|                  ID                  |   Status  | Display Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
| 3a888ac1-395a-4082-973e-139be9de97d9 | available |     bla1     |  10  |     bla     |  false   |             |
| 5fb0c74a-9540-4793-b386-d45ab5e4765a | available |    blaaa     |  11  |    dafna    |  false   |             |
| fb596f0d-30ff-4f74-b68e-41d14b791d9b | available |     bla      |  10  |    dafna    |  false   |             |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+

if I use:

cinder list --display-name bla we get the specific volume called bla: 

[root@opens-vdsb ~(keystone_admin)]# cinder list --display-name bla
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
|                  ID                  |   Status  | Display Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
| fb596f0d-30ff-4f74-b68e-41d14b791d9b | available |     bla      |  10  |    dafna    |  false   |             |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+ 

but if I run cinder list --display-name bla* we do not get an output. 

Version-Release number of selected component (if applicable):

openstack-cinder-2013.1.2-3.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. create several volumes
2. run 'cinder list --display-name' with wild card
3.

Actual results:

we do not get any output. 

Expected results:

we should be able to use a wild card since its a basic search in linux. 

Additional info:
Comment 1 Dafna Ron 2013-07-23 05:04:10 EDT
please note that we have the same for other cinder commands: 

[root@opens-vdsb ~(keystone_admin)]# cinder snapshot-list --display-name snap_sna*
[root@opens-vdsb ~(keystone_admin)]#
Comment 3 Ayal Baron 2013-12-18 02:52:32 EST
Haim / Dafna, please file upstream.

Note You need to log in before you can comment on or make changes to this bug.