Bug 986783 - [abrt] libreoffice-core-3.5.7.2-12.fc17: icu_48::LayoutEngine::mapCharsToGlyphs: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.7.2-12.fc17: icu_48::LayoutEngine::mapCharsToGlyp...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eike Rathke
Fedora Extras Quality Assurance
abrt_hash:b991819735cf003128d4b132da3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 01:44 EDT by Bruce Martin
Modified: 2013-08-03 19:55 EDT (History)
7 users (show)

See Also:
Fixed In Version: openttd-1.3.0-2.fc18
Doc Type: Bug Fix
Doc Text:
Cause: D. Tardon has requested more information from me (Bruce Martin AKA brucemartin10@gmail.com). Being new at interacting with Bugzilla I ma not sure what he needs, and may need some "Bugzilla handholding". Let this bug's participants know that yesterday I submitted a freeforn "bug" to advise some more information about the hardware here FYI. Beyond that, it is likely to my guess that D. Tardon and Eike Rathke will need other information, but what? Now what? Bruce Martin Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-27 21:13:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (48.77 KB, text/plain)
2013-07-22 01:44 EDT, Bruce Martin
no flags Details
File: cgroup (128 bytes, text/plain)
2013-07-22 01:44 EDT, Bruce Martin
no flags Details
File: core_backtrace (5.11 KB, text/plain)
2013-07-22 01:44 EDT, Bruce Martin
no flags Details
File: dso_list (19.93 KB, text/plain)
2013-07-22 01:45 EDT, Bruce Martin
no flags Details
File: environ (1.84 KB, text/plain)
2013-07-22 01:45 EDT, Bruce Martin
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-22 01:45 EDT, Bruce Martin
no flags Details
File: maps (90.06 KB, text/plain)
2013-07-22 01:45 EDT, Bruce Martin
no flags Details
File: open_fds (427 bytes, text/plain)
2013-07-22 01:45 EDT, Bruce Martin
no flags Details
File: proc_pid_status (941 bytes, text/plain)
2013-07-22 01:45 EDT, Bruce Martin
no flags Details
File: var_log_messages (360 bytes, text/plain)
2013-07-22 01:45 EDT, Bruce Martin
no flags Details

  None (edit)
Description Bruce Martin 2013-07-22 01:44:47 EDT
Version-Release number of selected component:
libreoffice-core-3.5.7.2-12.fc17

Additional info:
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc 'file:///home/Bruce/Link%20to%20Linux%20Links/Link%20to%20Bruce\'s%20Shop%20Projects/Jane\'s%20Television%20Cart/BOM,%20Jane\'s%20Television%20Cart.ods' --splash-pipe=6
crash_function: icu_48::LayoutEngine::mapCharsToGlyphs
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.9.10-100.fc17.x86_64
last_occurrence: 1374357529
runlevel:       N 5
uid:            1000
ureports_counter: 1
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 icu_48::LayoutEngine::mapCharsToGlyphs at LayoutEngine.cpp:472
 #1 IcuLayoutEngine::operator() at /usr/src/debug/libreoffice-3.5.7.2/vcl/generic/glyphs/gcach_layout.cxx:466
 #2 OutputDevice::ImplLayout at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/gdi/outdev3.cxx:6144
 #3 OutputDevice::GetTextArray at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/gdi/outdev3.cxx:5815
 #4 ImplListBoxWindow::ImplUpdateEntryMetrics at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/control/ilstbox.cxx:719
 #5 ImplListBoxWindow::InsertEntry at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/control/ilstbox.cxx:823
 #6 ImplListBox::InsertEntry at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/control/ilstbox.cxx:2306
 #7 ListBox::InsertEntry at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/control/lstbox.cxx:1051
 #8 SvxNumberFormatTabPage::FillCurrencyBox at /usr/src/debug/libreoffice-3.5.7.2/cui/source/tabpages/numfmt.cxx:1748
 #9 SvxNumberFormatTabPage::Reset at /usr/src/debug/libreoffice-3.5.7.2/cui/source/tabpages/numfmt.cxx:532
Comment 1 Bruce Martin 2013-07-22 01:44:52 EDT
Created attachment 776697 [details]
File: backtrace
Comment 2 Bruce Martin 2013-07-22 01:44:55 EDT
Created attachment 776698 [details]
File: cgroup
Comment 3 Bruce Martin 2013-07-22 01:44:59 EDT
Created attachment 776699 [details]
File: core_backtrace
Comment 4 Bruce Martin 2013-07-22 01:45:03 EDT
Created attachment 776700 [details]
File: dso_list
Comment 5 Bruce Martin 2013-07-22 01:45:06 EDT
Created attachment 776701 [details]
File: environ
Comment 6 Bruce Martin 2013-07-22 01:45:09 EDT
Created attachment 776702 [details]
File: limits
Comment 7 Bruce Martin 2013-07-22 01:45:12 EDT
Created attachment 776703 [details]
File: maps
Comment 8 Bruce Martin 2013-07-22 01:45:15 EDT
Created attachment 776704 [details]
File: open_fds
Comment 9 Bruce Martin 2013-07-22 01:45:19 EDT
Created attachment 776705 [details]
File: proc_pid_status
Comment 10 Bruce Martin 2013-07-22 01:45:22 EDT
Created attachment 776706 [details]
File: var_log_messages
Comment 11 David Tardon 2013-07-22 04:49:53 EDT
Is the crash reproducible?
Comment 12 Eike Rathke 2013-07-22 06:32:58 EDT
Was the ICU version by chance pulled from testing icu-4.8.1.1-6.fc17?
Comment 13 David Tardon 2013-07-22 09:09:30 EDT
Yes, it was. From dso_list:

/usr/lib64/libicule.so.48.1.1 libicu-4.8.1.1-6.fc17.x86_64 (Fedora Project) 1374175670

So this will be fixed by the rebuild we are doing right now.
Comment 14 Fedora Update System 2013-07-23 03:15:58 EDT
openttd-1.3.2-0.2.RC1.fc19,pyicu-1.5-2.fc19,fontmatrix-0.9.99-12.r1218.fc19,libreoffice-4.1.0.3-2.fc19,icu-50.1.2-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openttd-1.3.2-0.2.RC1.fc19,pyicu-1.5-2.fc19,fontmatrix-0.9.99-12.r1218.fc19,libreoffice-4.1.0.3-2.fc19,icu-50.1.2-7.fc19
Comment 15 Fedora Update System 2013-07-23 03:23:56 EDT
openttd-1.3.0-2.fc18,pyicu-1.4-2.fc18,fontmatrix-0.9.99-9.r1218.fc18,libreoffice-3.6.7.2-3.fc18,icu-49.1.1-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openttd-1.3.0-2.fc18,pyicu-1.4-2.fc18,fontmatrix-0.9.99-9.r1218.fc18,libreoffice-3.6.7.2-3.fc18,icu-49.1.1-10.fc18
Comment 16 Fedora Update System 2013-07-23 03:32:14 EDT
openttd-1.3.0-2.fc17,pyicu-1.2-3.fc17,fontmatrix-0.9.99-4.r1218.fc17,icu-4.8.1.1-7.fc17,libreoffice-3.5.7.2-14.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openttd-1.3.0-2.fc17,pyicu-1.2-3.fc17,fontmatrix-0.9.99-4.r1218.fc17,icu-4.8.1.1-7.fc17,libreoffice-3.5.7.2-14.fc17
Comment 17 Bruce Martin 2013-07-23 14:44:13 EDT
Cause: 

Intermediate:

D. Tardon has requested more information from me (Bruce Martin AKA brucemartin10@gmail.com).

Being new at interacting with Bugzilla I ma not sure what he needs, and may need some "Bugzilla handholding".

Let this bug's participants know that yesterday I submitted a freeforn "bug" to advise some more information about the hardware here FYI.

Beyond that, it is likely to my guess that D. Tardon and Eike Rathke will need other information, but what?

Now what?

Bruce Martin

Consequence: 

Fix: 

Result:
Comment 18 Bruce Martin 2013-07-23 14:46:34 EDT
Reproducible:

It reproduced itself from time to time, but I have no idea how or why.

Sorry if I missed this previously.
Comment 19 Eike Rathke 2013-07-23 15:37:26 EDT
(In reply to Bruce Martin from comment #17)
> Beyond that, it is likely to my guess that D. Tardon and Eike Rathke will
> need other information, but what?

It's alright, we identified the cause to be an update of the icu package in the testing repository that you seem to have activated for updates.

The next regular update of f17 should solve the problem, see also comment #16

In the mean time until that update is pushed to testing you can solve this specific problem on your machine by issuing a yum downgrade icu.

Thanks.
Comment 20 Fedora Update System 2013-07-27 21:13:43 EDT
openttd-1.3.2-0.2.RC1.fc19, pyicu-1.5-2.fc19, fontmatrix-0.9.99-12.r1218.fc19, libreoffice-4.1.0.3-2.fc19, icu-50.1.2-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2013-08-03 19:55:00 EDT
openttd-1.3.0-2.fc18, pyicu-1.4-2.fc18, fontmatrix-0.9.99-9.r1218.fc18, libreoffice-3.6.7.2-3.fc18, icu-49.1.1-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.