Bug 986826 - List running containers will auto-destroy these containers
List running containers will auto-destroy these containers
Status: CLOSED DUPLICATE of bug 990939
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt-sandbox (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
: 988335 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 04:09 EDT by Alex Jia
Modified: 2013-08-01 10:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 10:56:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Jia 2013-07-22 04:09:01 EDT
Description of problem:
List running containers will auto-destroy these containers.

Version-Release number of selected component (if applicable):

# rpm -q libvirt-sandbox libvirt systemd kernel selinux-policy
libvirt-sandbox-0.2.1-1.el7.x86_64
libvirt-1.1.0-2.el7.x86_64
systemd-204-9.el7.1.x86_64
kernel-3.10.0-1.el7.x86_64
selinux-policy-3.12.1-65.el7.noarch


How reproducible:
always

Steps to Reproduce:

1. for i in {1..5}; do virt-sandbox-service create -C -u httpd.service -N dhcp,source=default myapache$i; done
2. for i in {1..5}; do virt-sandbox-service start myapache$i & done
3. virsh -c lxc:// list
4. virt-sandbox-service list -r
5. repeat step 3

Actual results:

# for i in {1..5}; do virt-sandbox-service create -C -u httpd.service -N dhcp,source=default myapache$i; done
Created sandbox container dir /var/lib/libvirt/filesystems/myapache1
Created unit file /etc/systemd/system/myapache1_sandbox.service
Created sandbox config /etc/libvirt-sandbox/services/myapache1.sandbox
Created sandbox container dir /var/lib/libvirt/filesystems/myapache2
Created unit file /etc/systemd/system/myapache2_sandbox.service
Created sandbox config /etc/libvirt-sandbox/services/myapache2.sandbox
Created sandbox container dir /var/lib/libvirt/filesystems/myapache3
Created unit file /etc/systemd/system/myapache3_sandbox.service
Created sandbox config /etc/libvirt-sandbox/services/myapache3.sandbox
Created sandbox container dir /var/lib/libvirt/filesystems/myapache4
Created unit file /etc/systemd/system/myapache4_sandbox.service
Created sandbox config /etc/libvirt-sandbox/services/myapache4.sandbox
Created sandbox container dir /var/lib/libvirt/filesystems/myapache5
Created unit file /etc/systemd/system/myapache5_sandbox.service
Created sandbox config /etc/libvirt-sandbox/services/myapache5.sandbox

# for i in {1..5}; do virt-sandbox-service start myapache$i & done
[1] 18512
[2] 18513
[3] 18514
[4] 18515
[5] 18516

# virsh -c lxc:// list
 Id    Name                           State
----------------------------------------------------
 18555 myapache3                      running
 18634 myapache1                      running
 18713 myapache4                      running
 18793 myapache2                      running
 18871 myapache5                      running

# ps -ef|grep sandbox|grep -v grep
root     18512 31645  0 16:01 pts/0    00:00:00 virt-sandbox-service-util -c lxc:/// -s myapache1
root     18513 31645  0 16:01 pts/0    00:00:00 virt-sandbox-service-util -c lxc:/// -s myapache2
root     18514 31645  0 16:01 pts/0    00:00:00 virt-sandbox-service-util -c lxc:/// -s myapache3
root     18515 31645  0 16:01 pts/0    00:00:00 virt-sandbox-service-util -c lxc:/// -s myapache4
root     18516 31645  0 16:01 pts/0    00:00:00 virt-sandbox-service-util -c lxc:/// -s myapache5

# virt-sandbox-service list -r
myapache1
myapache2
myapache3
myapache4
myapache5

# virsh -c lxc:// list
 Id    Name                           State
----------------------------------------------------

# ps -ef|grep sandbox|grep -v grep

Expected results:


Additional info:

<libvirtd log slice>

2013-07-22 08:02:20.421+0000: 18321: debug : do_open:1321 : nwfilter driver 2 remote returned DECLINED
2013-07-22 08:02:20.421+0000: 18321: debug : do_open:1321 : nwfilter driver 3 nwfilter returned SUCCESS
2013-07-22 08:02:20.421+0000: 18318: debug : virConnectDomainEventRegisterAny:18764 : dom=(nil), (VM: name=(null), uuid=), conn=0x7f04c40049a0, eventID=0, cb=0x7f04f12b3be0, opaque=0x7f04f1910c30, freecb=(nil)
2013-07-22 08:02:20.423+0000: 18322: debug : virConnectNumOfDomains:1896 : conn=0x7f04c40049a0
2013-07-22 08:02:20.423+0000: 18320: debug : virConnectListDomains:1859 : conn=0x7f04c40049a0, ids=0x7f04d0181c50, maxids=5
2013-07-22 08:02:20.424+0000: 18319: debug : virConnectNumOfDefinedDomains:9073 : conn=0x7f04c40049a0
2013-07-22 08:02:20.424+0000: 18321: debug : virDomainLookupByID:2041 : conn=0x7f04c40049a0, id=18634
2013-07-22 08:02:20.424+0000: 18321: debug : virDomainFree:2322 : dom=0x7f04c40c75d0, (VM: name=myapache1, uuid=0cc72cf6-d568-45b3-91d1-66cb8f21651c)
2013-07-22 08:02:20.425+0000: 18318: debug : virDomainLookupByID:2041 : conn=0x7f04c40049a0, id=18555
2013-07-22 08:02:20.425+0000: 18318: debug : virDomainFree:2322 : dom=0x7f04d417a610, (VM: name=myapache3, uuid=1dee1955-db2d-4831-8238-3bdf1af350f9)
2013-07-22 08:02:20.426+0000: 18322: debug : virDomainLookupByID:2041 : conn=0x7f04c40049a0, id=18871
2013-07-22 08:02:20.426+0000: 18322: debug : virDomainFree:2322 : dom=0x7f04c800b660, (VM: name=myapache5, uuid=8127c83c-3e4e-4a5b-b22a-cba5dd3d2946)
2013-07-22 08:02:20.426+0000: 18320: debug : virDomainLookupByID:2041 : conn=0x7f04c40049a0, id=18793
2013-07-22 08:02:20.426+0000: 18320: debug : virDomainFree:2322 : dom=0x7f04d01810d0, (VM: name=myapache2, uuid=828e7914-52c5-4701-ae92-46fae3899639)
2013-07-22 08:02:20.427+0000: 18319: debug : virDomainLookupByID:2041 : conn=0x7f04c40049a0, id=18713
2013-07-22 08:02:20.427+0000: 18319: debug : virDomainFree:2322 : dom=0x7f04cc0088e0, (VM: name=myapache4, uuid=d547b57b-70a6-4c38-a72a-c0f96cf093bb)
2013-07-22 08:02:20.427+0000: 18321: debug : virConnectDomainEventDeregisterAny:18816 : conn=0x7f04c40049a0, callbackID=10
2013-07-22 08:02:20.428+0000: 18318: debug : virDomainDestroy:2213 : dom=0x7f04d417b440, (VM: name=myapache1, uuid=0cc72cf6-d568-45b3-91d1-66cb8f21651c)
2013-07-22 08:02:20.428+0000: 18318: debug : virLXCProcessStop:749 : Stopping VM name=myapache1 pid=18634 reason=2
2013-07-22 08:02:20.436+0000: 18317: error : virNetSocketReadWire:1379 : End of file while reading data: Input/output error
2013-07-22 08:02:20.436+0000: 18317: debug : virLXCMonitorEOFNotify:121 : EOF notify mon=0x7f04c800c010
2013-07-22 08:02:20.436+0000: 18317: debug : virLXCMonitorEOFNotify:128 : EOF callback mon=0x7f04c800c010 vm=0x7f04c8003820
2013-07-22 08:02:20.436+0000: 18317: debug : virLXCProcessMonitorEOFNotify:561 : mon=0x7f04c800c010 vm=0x7f04c8003820
2013-07-22 08:02:22.231+0000: 18318: debug : virLXCProcessCleanup:229 : Stopping VM name=myapache1 pid=18634 reason=2
2013-07-22 08:02:22.231+0000: 18318: debug : virLXCProcessAutoDestroyRemove:150 : vm=myapache1 uuid=0cc72cf6-d568-45b3-91d1-66cb8f21651c
2013-07-22 08:02:22.231+0000: 18318: debug : virLXCMonitorClose:210 : mon=0x7f04c800c010
2013-07-22 08:02:22.231+0000: 18318: debug : virLXCMonitorClose:216 : Clear EOF callback mon=0x7f04c800c010
2013-07-22 08:02:22.235+0000: 18318: error : virNetDevSetOnline:598 : Cannot get interface flags on 'veth1': No such device
2013-07-22 08:02:22.244+0000: 18318: error : virCommandWait:2351 : internal error Child process (ip link del veth1) unexpected exit status 1: Cannot find device "veth1"

2013-07-22 08:02:22.251+0000: 18318: debug : virDomainFree:2322 : dom=0x7f04d417b440, (VM: name=myapache1, uuid=0cc72cf6-d568-45b3-91d1-66cb8f21651c)
2013-07-22 08:02:22.251+0000: 18317: debug : virLXCProcessStop:749 : Stopping VM name=myapache1 pid=-1 reason=1
2013-07-22 08:02:22.251+0000: 18317: debug : virLXCProcessStop:751 : VM 'myapache1' not active
2013-07-22 08:02:22.251+0000: 18317: debug : virLXCProcessStop:749 : Stopping VM name=myapache1 pid=-1 reason=1
2013-07-22 08:02:22.251+0000: 18317: debug : virLXCProcessStop:751 : VM 'myapache1' not active
2013-07-22 08:02:22.251+0000: 18317: debug : virLXCProcessMonitorEOFNotify:577 : Stop event has already been sent
2013-07-22 08:02:22.251+0000: 18317: debug : virLXCMonitorDispose:201 : mon=0x7f04c800c010
2013-07-22 08:02:22.252+0000: 18317: debug : virConnectClose:1490 : conn=0x7f04c40049a0
2013-07-22 08:02:22.252+0000: 18317: debug : virLXCProcessAutoDestroyRun:124 : conn=0x7f04c40049a0

</libvirtd log slice>
Comment 2 Daniel Walsh 2013-07-26 12:33:51 EDT
*** Bug 988335 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Berrange 2013-08-01 10:56:23 EDT

*** This bug has been marked as a duplicate of bug 990939 ***

Note You need to log in before you can comment on or make changes to this bug.