Bug 986827 - Entry Point not found "strnlen" in "msvcrt.dll"
Entry Point not found "strnlen" in "msvcrt.dll"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mingw32-webkitgtk (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Erik van Pienbroek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 04:12 EDT by Mikkel Kruse Johnsen
Modified: 2013-07-24 20:51 EDT (History)
1 user (show)

See Also:
Fixed In Version: mingw-fontconfig-2.10.93-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 20:45:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikkel Kruse Johnsen 2013-07-22 04:12:37 EDT
Description of problem:
Unable to start "GtkLauncher-3.exe" on Windows XP

Version-Release number of selected component (if applicable):
mingw32-webkitgtk3-2.0.3-3.fc19.noarch


How reproducible:
Every time

Steps to Reproduce:
1. Start "GtkLuancher-3.exe" on Windows XP

Actual results:
Entry Point "strnlen" not found in "msvcrt.dll"


Expected results:
Webkit browser to start


Additional info:
It worked on Fedora 18.

I think it has something to do with mingw32-crt, it has a patch (mingw-w64-commit-r5898.patch) but only for x64, that deals with "msvcrt.dll".

The mingw32-crt in Fedora 18 did not have that patch.

I have tried to use the mingw32-crt, mingw32-webkitgtk3, cairo, gdk-pixbuf from Fedora 20. but it did not work.

I have tried to recompile mingw32-crt without the patch (mingw-w64-commit-r5898.patch) and recompile webkitgtk3. but it did not work.
Comment 1 Erik van Pienbroek 2013-07-22 14:48:15 EDT
Hi Mikkel,

Apparently we missed each other on IRC. Anyway, the root cause for this issue was already found and fixed upstream: http://thread.gmane.org/gmane.comp.gnu.mingw.w64.general/7935
Yesterday I pushed an updated mingw-fontconfig package to f19-updates-testing which should fix the problems
Comment 2 Fedora Update System 2013-07-23 02:33:35 EDT
mingw-fontconfig-2.10.93-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-13420/mingw-fontconfig-2.10.93-2.fc19
Comment 3 Fedora Update System 2013-07-23 02:34:14 EDT
mingw-crt-2.0.999-0.30.trunk.r5969.20130721.fc19, mingw-headers-2.0.999-0.30.trunk.r5969.20130721.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-13445/mingw-crt-2.0.999-0.30.trunk.r5969.20130721.fc19,mingw-headers-2.0.999-0.30.trunk.r5969.20130721.fc19
Comment 4 Mikkel Kruse Johnsen 2013-07-23 03:45:13 EDT
I have testet the new packages and it works on Windows XP.
Comment 5 Erik van Pienbroek 2013-07-23 13:55:23 EDT
That's good to hear.
Could you give karma to the updates in question? That way they'll be pushed to stable and this bug report will get closed automatically
Comment 6 Fedora Update System 2013-07-24 20:45:33 EDT
mingw-crt-2.0.999-0.30.trunk.r5969.20130721.fc19, mingw-headers-2.0.999-0.30.trunk.r5969.20130721.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-07-24 20:51:22 EDT
mingw-fontconfig-2.10.93-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.