Bug 986860 - Fail to add Jenkins-client cartridge to a scaled app
Fail to add Jenkins-client cartridge to a scaled app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 05:27 EDT by Zhe Wang
Modified: 2015-05-14 19:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:55:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Correspoindnig error msg in mcollective.log (7.55 KB, text/x-log)
2013-07-22 05:47 EDT, Zhe Wang
no flags Details
Correspoindnig error msg in development.log (23.47 KB, text/x-log)
2013-07-22 05:47 EDT, Zhe Wang
no flags Details

  None (edit)
Description Zhe Wang 2013-07-22 05:27:19 EDT
Description of problem:
Given a scaling app with auto scaling disabled, it fails to add a Jenkins-client cartridge to it after scaling it up. On the other hand, there is no such problem if we do not scale up the app before adding Jekins-client cartridge.

Version-Release number of selected component (if applicable):
devenv_3535

How reproducible:
always

Steps to Reproduce:
1. create a scaling app

2. disable its auto scaling by touching a disable_auto_scaling marker

3. push the marker to its repo

4. scale up the app with REST API

5. create a Jenkins server app

6. embed a Jenkins-client cartridge to this app

7. check the gear groups of this app via REST API

Actual results:
Adding a Jenkins-client cartridge to the scaled up app fails with the error below:

Using jenkins-client-1.4 (Jenkins Client 1.4) for 'jenkins-client'
Adding jenkins-client-1.4 to application 'srb9' ... Unexpected error: User does not exist in cgroups: 447847664739953338744832

Moreover, in Step 7, it turns out that the UUID in the error in Step 6 referrs to the scaled-up gear.

Expected results:
It should be successful to add a Jenkins-client cartridge to a scaled app.

Additional info:
Comment 1 Zhe Wang 2013-07-22 05:47:04 EDT
Created attachment 776828 [details]
Correspoindnig error msg in mcollective.log
Comment 2 Zhe Wang 2013-07-22 05:47:36 EDT
Created attachment 776829 [details]
Correspoindnig error msg in development.log
Comment 3 Zhe Wang 2013-07-29 04:58:15 EDT
The bug has been fixed in devenv_3574, and the steps are identical to those in the description.

Result:

[zhe@fedora run106]$ rhc cartridge add jenkins-client -a spy27
Using jenkins-client-1.4 (Jenkins Client 1.4) for 'jenkins-client'
Adding jenkins-client-1.4 to application 'spy27' ... done

jenkins-client-1.4 (Jenkins Client 1.4)
---------------------------------------
  Gears:   Located with python-2.7, haproxy-1.4
  Job URL: https://jenkins-dev3574tst.dev.rhcloud.com/job/spy27-build/

Associated with job 'spy27-build' in Jenkins server.

Would you please move this bug to ON_QA, so that I can archive this bug as VERIFIED then.

Thanks,
Zhe Wang
Comment 4 Rajat Chopra 2013-07-29 15:09:47 EDT
Fixed with rev#0bc92a9d4b75514bf667eacdf356581b055d6b6c
Comment 5 Zhe Wang 2013-07-29 22:01:34 EDT
Move the bug to VERIFIED referring to Comment #3.

Note You need to log in before you can comment on or make changes to this bug.