Bug 986869 - PRESET: add nfs.target to preset file
PRESET: add nfs.target to preset file
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 05:52 EDT by Jóhann B. Guðmundsson
Modified: 2013-07-22 12:03 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 10:39:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add nfs.target to preset (858 bytes, patch)
2013-07-22 05:57 EDT, Jóhann B. Guðmundsson
no flags Details | Diff

  None (edit)
Description Jóhann B. Guðmundsson 2013-07-22 05:52:23 EDT
Description of problem:

The necessary split up of the nfs related service which got put into it's own target is causing several bugs and usability issue ( since users need to enable the target and the nfs service ) 

See #970595 #983915 etc...

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2013-07-22 05:57:28 EDT
Created attachment 776844 [details]
add nfs.target to preset
Comment 2 Zbigniew Jędrzejewski-Szmek 2013-07-22 10:14:12 EDT
Hm, so nfs.target, which requires rpcbind.service, would be always enabled. This doesn't seem to be a good solution. Maybe if the users are expecting 'systemctl enable nfs.service' to do the whole job, it would be better to add '[Install] Also=nfs.target' to nfs.service?
Comment 3 Jóhann B. Guðmundsson 2013-07-22 10:39:33 EDT
(In reply to Zbigniew Jędrzejewski-Szmek from comment #2)
> Hm, so nfs.target, which requires rpcbind.service, would be always enabled.
> This doesn't seem to be a good solution. Maybe if the users are expecting
> 'systemctl enable nfs.service' to do the whole job, it would be better to
> add '[Install] Also=nfs.target' to nfs.service?

That would be one way of solving it anyway closing this since it's best to leave it up to Steve to clean up his own mess and his "feelings" instead of us being wasting our time and effort trying to help him out. 

He can the re-propose this when he realizes that it's necessary and "feels" like it.
Comment 4 Michal Schmidt 2013-07-22 11:22:04 EDT
Could someone explain to me what the semantical *meaning* of nfs.target is? If I (as a Fedora user) do systemctl enable nfs.target, what is it that I am really enabling?
(To be clear, I would not consider a reply "Just look at the unit files' deps!" satisfactory. I really want to know what the *intent* is. How it is *supposed to* work from the user's point of view.)
Comment 5 Jóhann B. Guðmundsson 2013-07-22 12:03:04 EDT
(In reply to Michal Schmidt from comment #4)
> Could someone explain to me what the semantical *meaning* of nfs.target is?
> If I (as a Fedora user) do systemctl enable nfs.target, what is it that I am
> really enabling?
> (To be clear, I would not consider a reply "Just look at the unit files'
> deps!" satisfactory. 

I would not do that since you would have to look at two places what I submitted and what Steve then implemented I guess based on his feelings without looking into the units and dependency in them and their correlation to the nfs.target 
( instead of actually implement the whole set of submitted units he decided to cherry pick some of them while leaving some of unsplitted ones as is )

> I really want to know what the *intent* is. How it is
> *supposed to* work from the user's point of view.)

That you enable activate that target only ( as the command suggest ) you then can proceed with enabling the rest of all the services within the target since they are dependent on various implementation/setup of nfs in infrastructure ( and the dependency in the services ) and easily disable nfs along with all the services by simply disabling the target itself. 

The target itself was always meant to be enabled when you install the nfs-utils package since it takes care of the shared dependency in all of the nfs units.

Note You need to log in before you can comment on or make changes to this bug.