Bug 986878 - glusterfs-server package exits with non-zero status while upgrading
glusterfs-server package exits with non-zero status while upgrading
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribution (Show other bugs)
2.1
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Bala.FA
Sachidananda Urs
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 06:17 EDT by Sachidananda Urs
Modified: 2015-11-22 21:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2013-07-22 06:17:32 EDT
Description of problem:

While upgrading from U5 to Big Bend, glusterfs-server package exits with a non-zero error code.

Error below:

Updating   : glusterfs-server-3.4.0.12rhs.beta5-2.el6rhs.x86_64           203/621 
Non-fatal POSTIN scriptlet failure in rpm package glusterfs-server-3.4.0.12rhs.beta5-2.el6rhs.x86_64
warning: /etc/glusterfs/group-virt.example created as /etc/glusterfs/group-virt.example.rpmnew
warning: %post(glusterfs-server-3.4.0.12rhs.beta5-2.el6rhs.x86_64) scriptlet failed, exit status 1


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Amar Tumballi 2013-07-23 05:35:11 EDT
Bala/Kaushal, can you guys check whats the issue? and see if its easy to fix? This is a blocker for the release.
Comment 4 Bala.FA 2013-07-23 07:23:29 EDT
I tried to reproduce this by

1. install http://download.eng.blr.redhat.com/pub/rhs/rel-eng/RHS-2.0-20130715.0/2/RHS/x86_64/os/

2. download glusterfs rpms from http://download.devel.redhat.com/brewroot/packages/glusterfs/3.4.0.12rhs.beta5/2.el6rhs/x86_64/

3. run rpm -Uvh glusterfs-3.4.0.12rhs.beta5-2.el6rhs.x86_64.rpm glusterfs-fuse-3.4.0.12rhs.beta5-2.el6rhs.x86_64.rpm glusterfs-server-3.4.0.12rhs.beta5-2.el6rhs.x86_64.rpm glusterfs-rdma-3.4.0.12rhs.beta5-2.el6rhs.x86_64.rpm glusterfs-geo-replication-3.4.0.12rhs.beta5-2.el6rhs.x86_64.rpm

This succeeded ie exit status is 0

4. tried yum localupdate glusterfs-3.4.0.12rhs.beta5-2.el6rhs.x86_64.rpm glusterfs-fuse-3.4.0.12rhs.beta5-2.el6rhs.x86_64.rpm glusterfs-server-3.4.0.12rhs.beta5-2.el6rhs.x86_64.rpm glusterfs-rdma-3.4.0.12rhs.beta5-2.el6rhs.x86_64.rpm glusterfs-geo-replication-3.4.0.12rhs.beta5-2.el6rhs.x86_64.rpm

This also succeeded ie exit status is 0

I am not sure how to reproduce this
Comment 5 Sachidananda Urs 2013-07-23 07:39:34 EDT
1. Ensure your machine is on Update-5
2. Subscribe to RHEL-6.4.z base channel
3. Subscribe to RHS-2.1 channel
4. yum update

I am sending you the account details to subscribe to in a separate email.
Comment 6 Bala.FA 2013-07-24 04:55:24 EDT
I followed those steps except 'yum update --nogpgcheck' and there is no problem found.  As rpms in rhn.qa are not signed, we need to add --nogpgcheck and it works fine.

Let me know what you think.
Comment 7 Sachidananda Urs 2013-08-08 01:52:33 EDT
I do not see the error in the latest runs. Ran the upgrade twice, but don't see the error. Verified for now.
Comment 8 Scott Haines 2013-09-23 18:29:50 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.