Bug 986885 - Dist-geo-rep : geo-rep cascading is broken and intermediate master says master is corrupt
Dist-geo-rep : geo-rep cascading is broken and intermediate master says maste...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Avra Sengupta
Vijaykumar Koppad
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 06:38 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:50 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:29:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-07-22 06:38:12 EDT
Description of problem: Geo-rep cascading setup will faulty at intermediate master and the geo-rep logs at intermediate master says, 
 
[2013-07-22 15:44:28.378478] I [master(/bricks/brick1):500:crawlwrap] _GMaster: crawl interval: 60 seconds
[2013-07-22 15:44:28.489165] E [syncdutils(/bricks/brick1):184:log_raise_exception] <top>: master is corrupt
[2013-07-22 15:44:28.489896] I [syncdutils(/bricks/brick1):158:finalize] <top>: exiting.
^C


Version-Release number of selected component (if applicable):3.4.0.12rhs.beta5-2.el6rhs.x86_64


How reproducible:Happens everytime


Steps to Reproduce:
1.create 3 clusters, master, imaster and slave
2.create and start a geo-rep session between master and imaster.
3.Then create a geo-rep session between imaster and slave.
4.After creating geo-rep between imaster and slave, imaster become intermediate master.
5.Check geo-rep status ate intermediate master.  

Actual results:Intermediate master status will be faulty  and log says master is corrupt. 


Expected results: Intermediate master status should stable. 


Additional info:
Comment 3 Amar Tumballi 2013-07-23 08:28:19 EDT
https://code.engineering.redhat.com/gerrit/#/c/10626
Comment 4 Vijaykumar Koppad 2013-07-25 04:34:04 EDT
verified in glusterfs-3.4.0.12rhs.beta6-1
Comment 5 Scott Haines 2013-09-23 18:29:51 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.