Bug 986887 - mkrpm fails on x86_64
mkrpm fails on x86_64
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: dkms (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Simone Caronni
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 06:42 EDT by Dave Love
Modified: 2013-08-07 14:13 EDT (History)
3 users (show)

See Also:
Fixed In Version: dkms-2.2.0.3-14.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 23:37:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix hang with mkrpm (517 bytes, patch)
2013-07-22 08:28 EDT, Dave Love
no flags Details | Diff

  None (edit)
Description Dave Love 2013-07-22 06:42:24 EDT
Description of problem:

"dkms mkrpm" fails on x86_64 because it tries to run
/usr/lib/dkms/find-provides
and find-provides is actually in /usr/lib64/dkms/.

If I link /usr/lib/dkms to /usr/lib64/dkms, it then hangs running
gzip on the tarball it makes, according to ps.
Sorry I haven't time to debug it.

Version-Release number of selected component (if applicable):

2.2.0.3-8.el6

How reproducible:

Consistently.

Steps to Reproduce:
1. dkms mkrpm -m ... -v ...
2. ln -s /usr/lib64/dkms /usr/lib
3. dkms mkrpm -m ... -v ...
Comment 1 Simone Caronni 2013-07-22 07:14:08 EDT
Thanks for reporting.

Can you please test dkms-2.2.0.3-12.el6?

http://koji.fedoraproject.org/koji/buildinfo?buildID=436564
http://koji.fedoraproject.org/koji/packageinfo?packageID=1605

Thanks,
--Simone
Comment 2 Dave Love 2013-07-22 08:28:03 EDT
Created attachment 776887 [details]
fix hang with mkrpm

I just realize what was causing the hang.  There was an existing compressed
result and gzip was run without --force.
Comment 3 Simone Caronni 2013-07-22 08:47:43 EDT
Did you patch the package in comment #1 or the one that was installed in your system?
Comment 4 Simone Caronni 2013-07-22 10:00:04 EDT
Can you please test this build? Is comment #1's package with your patch. No lib64/lib link should be required:

http://koji.fedoraproject.org/koji/buildinfo?buildID=436634
Comment 5 Dave Love 2013-07-22 12:46:36 EDT
(In reply to Simone Caronni from comment #3)
> Did you patch the package in comment #1 or the one that was installed in
> your system?

The latter.  I haven't had time to try the new version yet, not used
to such a swift response, thanks!

I assume it's only necessary because the previous attempt to build the
rpm failed and left the file around, but I think the compression
should always be forced, and not hang the script with an existing output file.
Comment 6 Simone Caronni 2013-07-22 12:51:18 EDT
(In reply to Dave Love from comment #5)
> I assume it's only necessary because the previous attempt to build the
> rpm failed and left the file around, but I think the compression
> should always be forced, and not hang the script with an existing output
> file.

Agree, but the fix I added in comment #1 is needed anyway, some parts of DKMS have hard-coded /usr/lib/dkms paths in.

Package from comment #4 should contain both fixes.
Comment 7 Fedora Update System 2013-07-23 04:31:33 EDT
dkms-2.2.0.3-14.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-14.fc19
Comment 8 Fedora Update System 2013-07-23 04:31:59 EDT
dkms-2.2.0.3-14.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-14.fc18
Comment 9 Fedora Update System 2013-07-23 04:32:27 EDT
dkms-2.2.0.3-14.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-14.fc17
Comment 10 Fedora Update System 2013-07-23 04:33:04 EDT
dkms-2.2.0.3-14.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-14.el6
Comment 11 Fedora Update System 2013-07-23 04:33:33 EDT
dkms-2.2.0.3-14.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-14.el5
Comment 12 Simone Caronni 2013-07-23 04:34:40 EDT
Please leave feedback in Bodhi!
Comment 13 Fedora Update System 2013-07-23 15:39:11 EDT
Package dkms-2.2.0.3-14.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing dkms-2.2.0.3-14.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-10949/dkms-2.2.0.3-14.el6
then log in and leave karma (feedback).
Comment 14 Dave Love 2013-07-24 07:02:32 EDT
(In reply to Simone Caronni from comment #12)
> Please leave feedback in Bodhi!

I don't know what that means, but I think the current version fixes the
problem and this can be closed, thanks.
Comment 15 Fedora Update System 2013-08-01 23:37:04 EDT
dkms-2.2.0.3-14.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-08-01 23:53:50 EDT
dkms-2.2.0.3-14.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-08-07 14:11:23 EDT
dkms-2.2.0.3-14.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-08-07 14:13:14 EDT
dkms-2.2.0.3-14.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.