Bug 986890 - clc-intercal-0-0.12.1._94._2.fc20 does not build with Per 5.18
clc-intercal-0-0.12.1._94._2.fc20 does not build with Per 5.18
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: clc-intercal (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Iain Arnell
Fedora Extras Quality Assurance
https://koji.fedoraproject.org/koji/t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 06:51 EDT by Petr Pisar
Modified: 2013-08-02 17:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-02 17:09:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2013-07-22 06:51:41 EDT
clc-intercal-0-0.12.1._94._2.fc20 fails to build with Perl 5.18:

/usr/bin/perl -Iblib/arch -Iblib/lib -Iblib/arch -Iblib/lib -I./blib/arch -I./blib/lib ./blib/script/sick --nouserrc --batch --bug=0 --ubug=0 --stdtrace=/dev/null --notrace -lObject -pasm --output blib/lib/Language/INTERCAL/Include/syscall.io blib/lib/Language/INTERCAL/Include/syscall.iasm
Invalid object - did not provide a type
make[1]: Leaving directory `/builddir/build/BUILD/CLC-INTERCAL-1.-94.-2/CLC-INTERCAL-Base-1.-94.-2'
make[1]: *** [blib/lib/Language/INTERCAL/Include/syscall.io] Error 255
make: *** [all] Error 2
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.q0vx0B (%build)

Is it because of the clc-intercal-perl-5-12.patch patch?

--- CLC-INTERCAL-1.-94.-2/CLC-INTERCAL-ICALC-1.-94.-2/bin/intercalc.orig       2008-03-29 18:12:29.000000000 +0100
+++ CLC-INTERCAL-1.-94.-2/CLC-INTERCAL-ICALC-1.-94.-2/bin/intercalc     2010-05-28 16:02:12.000000000 +0200
@@ -627,6 +627,7 @@ sub find_objects {
     my %of = ();
     my $code = sub {
        my ($name, $file, $type, $object) = @_;
+       defined $type or return;
        exists $object_types{uc($type)} or return;
        my $ot = $object_types{uc($type)};
        defined $ot or return;
Comment 1 Iain Arnell 2013-08-02 17:09:48 EDT
No, it's not related to the existing patch. After spending hours on this, I finally tracked it down to a bug in the character set guessing code.

Note You need to log in before you can comment on or make changes to this bug.