Bug 986902 - Unexpected error before any request parameters read: java.io.IOException: Broken pipe
Unexpected error before any request parameters read: java.io.IOException: Bro...
Status: CLOSED NOTABUG
Product: JBoss Data Grid 6
Classification: JBoss
Component: Server (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: CR1
: 6.2.0
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 07:41 EDT by Jakub Markos
Modified: 2013-10-07 06:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 06:12:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Local node (11.81 KB, text/xml)
2013-07-22 07:41 EDT, Jakub Markos
no flags Details
Remote store (10.42 KB, text/xml)
2013-07-22 07:42 EDT, Jakub Markos
no flags Details
Remote store log (476.78 KB, application/zip)
2013-07-22 07:43 EDT, Jakub Markos
no flags Details
Local node log (92.81 KB, text/x-log)
2013-07-22 07:45 EDT, Jakub Markos
no flags Details

  None (edit)
Description Jakub Markos 2013-07-22 07:41:18 EDT
Created attachment 776871 [details]
Local node

In our tests for remote cache store I see a lot of "Unexpected error before any request parameters read: java.io.IOException: Broken pipe" (around 300 000 lines).
The tests pass (and are located here https://code.engineering.redhat.com/gerrit/gitweb?p=jdg-functional-tests.git;a=blob;f=remote/remote-cache-store/src/test/java/com/jboss/datagrid/test/remotestore/RemoteCacheStoreTest.java;h=310c1c7f297b5c45c32911a08a39458c3b17a295;hb=HEAD )
Server configs and logs attached.
Comment 1 Jakub Markos 2013-07-22 07:42:18 EDT
Created attachment 776872 [details]
Remote store
Comment 2 Jakub Markos 2013-07-22 07:43:05 EDT
Created attachment 776874 [details]
Remote store log
Comment 3 Jakub Markos 2013-07-22 07:45:51 EDT
Created attachment 776875 [details]
Local node log

Forgot to add that the errors appear with all 3 test methods, the logs are from a run where only testReadOnly was executed.
Comment 5 Tomas Sykora 2013-09-10 08:19:59 EDT
@jmarkos: I'm not able to reproduce this with 6.2.0.DR4 -- can you verify this please?
Comment 6 Jakub Markos 2013-09-10 08:53:08 EDT
It's still actual for DR4.
Comment 7 Jakub Markos 2013-10-07 05:39:15 EDT
Couldn't reproduce this on 6.2.0.ER2. Should I close it?
Comment 8 Martin Gencur 2013-10-07 06:12:52 EDT
Can't reproduce this issues anymore.

Note You need to log in before you can comment on or make changes to this bug.