Bug 986905 - afr: self heal of files failed when simulated a disk replacement scenario
afr: self heal of files failed when simulated a disk replacement scenario
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
pre-release
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Pranith Kumar K
: TestBlocker
Depends On: 975754
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 07:57 EDT by Pranith Kumar K
Modified: 2014-04-17 07:43 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 975754
Environment:
Last Closed: 2014-04-17 07:43:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-07-22 08:06:14 EDT
REVIEW: http://review.gluster.org/5370 (cluster/afr: Handle parallel hardlinks self-heal) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Anand Avati 2013-07-23 03:34:16 EDT
COMMIT: http://review.gluster.org/5370 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit eef0737ca6ae8056d906c7bff0a9280cc748270e
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Jul 22 16:44:09 2013 +0530

    cluster/afr: Handle parallel hardlinks self-heal
    
    Change-Id: Ieda11870c65edae500140b6c061f15a7b3f264f3
    BUG: 986905
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/5370
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Niels de Vos 2014-04-17 07:43:52 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.