Bug 986929 - dist-geo-rep: create/link/unlink results in data loss on the slave
dist-geo-rep: create/link/unlink results in data loss on the slave
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
Unspecified Linux
high Severity high
: ---
: ---
Assigned To: Venky Shankar
Vijaykumar Koppad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 08:53 EDT by Venky Shankar
Modified: 2014-08-24 20:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Venky Shankar 2013-07-22 08:53:10 EDT
Description of problem:
 An operation like the following would result in gsyncd
   trying to retry the CHANGELOG again and again:

      CREATE GFID PARGFID/BNAME
      WRITE GFID
      ...
      ...
      LINK PARGFID/NAME PARGFID1/BNAME1
      ...
      ...
      UNLINK PARGFID/BNAME

   Since entry operations are performed first, the object
   represented by PARGFID/BNAME (GFID) is no longer present
   on the slave. But beacuse of an hardlink operation the
   object still exist on the master. This causes data loss 
   on the slave (for the hardlink).


Version-Release number of selected component (if applicable):


How reproducible:

Always


Steps to Reproduce:
0. Start Geo-replication b/w master and slave
1. Create a file on master and write data to the file.
2. Create an hardlink to the above file
3. unlink the file created in Step 1

Actual results:

The hardlink is created on the slave but had 0 bytes (empty file).

Expected results:
master and slave should be in sync.

Additional info:
Comment 3 Vijaykumar Koppad 2013-08-07 03:57:15 EDT
verified on glusterfs-3.4.0.17rhs-1.el6rhs.x86_64
Comment 4 Scott Haines 2013-09-23 18:38:45 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 5 Scott Haines 2013-09-23 18:41:29 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.