Bug 986931 - A fullscreen window is completely hidden when another window is shown
A fullscreen window is completely hidden when another window is shown
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 08:53 EDT by Daniel Berrange
Modified: 2014-12-18 11:25 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-18 11:25:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2013-07-22 08:53:33 EDT
Description of problem:

Since upgrading from F18 to F19 I'm seeing strange behaviour with GNOME Shell and full screen windows.

If I have two windows on the desktop, say one GNOME Terminal and one GIMP window, and I maximise the gimp window. If I then alt-tab to the terminal window, the entire GIMP window is hidden. IIRC, in previous Fedora 18 GNOME, it would be shifted underneath the terminal window, rather than hidden.

The problem is even worse - when certain GIMP dialog windows are shown, these too will cause the entire main GIMP window to be hidden, along with the dialog itself.


Version-Release number of selected component (if applicable):
gnome-shell-3.8.3-3.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start GNOME terminal
2. Start GIMP
3. Ensure GIMP is using Single Window Mode (see checkbox under Windows menu)
4. With GIMP window active press F11 to maximise to full screen without any window decorations
5. Alt-tab to the GNOME terminal window
6. Alt-tab back to GIMP window
7. Select File -> new from GIMP menu

Actual results:
At step 5. the fullscreen GIMP window is hidden completely
At step 6. the fullscreen GIMP window reappears
At step 7. the fullscreen GIMP window and the new image popup are both hidden completely

Expected results:
At step 5. the fullscreen GIMP window is moved underneath the terminal window
At step 6. the fullscreen GIMP window is moved back above the termianl window
At step 7, the fullscreen GIMP window is not changed. The image popup displays above the GIMP window.

IOW, the fullscreen windows remain visible at all times. They should only be hidden in direct response to the user asking for them to be minimized.


Additional info:
Comment 1 Florian Müllner 2013-07-25 12:20:39 EDT
(In reply to Daniel Berrange from comment #0)
> If I have two windows on the desktop, say one GNOME Terminal and one GIMP
> window, and I maximise the gimp window. If I then alt-tab to the terminal
> window, the entire GIMP window is hidden. IIRC, in previous Fedora 18 GNOME,
> it would be shifted underneath the terminal window, rather than hidden.

Correct. This was an intentional change, as partially hidden fullscreen windows underneath system chrome / other windows are a bit odd (at least according to the GNOME designers).


> The problem is even worse - when certain GIMP dialog windows are shown,
> these too will cause the entire main GIMP window to be hidden, along with
> the dialog itself.

Yes, this one is a bug, see some discussion in https://bugzilla.gnome.org/show_bug.cgi?id=698641
Comment 2 Timur Kristóf 2014-11-30 18:03:48 EST
I think this behaviour has been changed and thus this issue has been solved in Fedora 21's gnome-shell.
Comment 3 Florian Müllner 2014-12-18 11:25:41 EST
(In reply to Timur Kristóf from comment #2)
> I think this behaviour has been changed and thus this issue has been solved
> in Fedora 21's gnome-shell.

Indeed.

Note You need to log in before you can comment on or make changes to this bug.