Bug 986988 - The engine-notifierd service is not restarted after a failed upgrade and rollback to 3.1.
The engine-notifierd service is not restarted after a failed upgrade and roll...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.2.0
x86_64 Linux
high Severity high
: ---
: 3.2.2
Assigned To: Alex Lourie
Ilanit Stein
integration
: ZStream
Depends On: 976514
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 10:45 EDT by Idith Tal-Kohen
Modified: 2013-11-27 19:10 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The engine-notifierd service is now restarted when the Manager is rolled back to a previous version after a failed upgrade, if it had been running before the upgrade.
Story Points: ---
Clone Of: 976514
Environment:
Last Closed: 2013-08-13 09:08:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 411063 None None None Never

  None (edit)
Description Idith Tal-Kohen 2013-07-22 10:45:06 EDT
+++ This bug was initially created as a clone of Bug #976514 +++

Description of problem:
The engine-notifierd service is not restarted after a failed upgrade and rollback to 3.1.

Version-Release number of selected component (if applicable):
rhevm-setup-3.2.0-11.30.el6ev.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Enable and start the engine-notifierd service.
2. Attempt to upgrade from 3.1 to 3.2, ensuring it fails and results in a rollback. For example I used BZ#975022.
3. Once the rollback is complete the engine-notifierd service is still down.

Actual results:
engine-notifierd service is still down.


Expected results:
engine-notifierd service has restarted.

Additional info:
Comment 2 Ilanit Stein 2013-07-29 06:46:29 EDT
Verified on rhevm-3.1.0-53.bz923443.el6ev.noarch to sf19 upgrade (failed & roll backed)
Comment 3 errata-xmlrpc 2013-08-13 09:08:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1149.html

Note You need to log in before you can comment on or make changes to this bug.