Bug 987079 - setup-ds.pl takes very long time
setup-ds.pl takes very long time
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 12:28 EDT by Martin Kosek
Modified: 2013-07-23 02:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 02:57:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of setup-ds.pl (389.74 KB, text/plain)
2013-07-22 12:30 EDT, Martin Kosek
no flags Details
IPA server install log (14.77 KB, text/plain)
2013-07-22 12:31 EDT, Martin Kosek
no flags Details
Successful, but very long run of setup-ds.pl (26.57 KB, application/gzip)
2013-07-22 12:35 EDT, Martin Kosek
no flags Details

  None (edit)
Description Martin Kosek 2013-07-22 12:28:47 EDT
Description of problem:
After upgrade to the latest RHEL-7.0 packages, I am no longer able to install IPA due to setup-ds.pl freezing without any error message:

# ipa-server-install
...
Continue to configure the system with these values? [no]: y

The following operations may take some minutes to complete.
Please wait until the prompt is returned.

Configuring NTP daemon (ntpd)
  [1/4]: stopping ntpd
  [2/4]: writing configuration
  [3/4]: configuring ntpd to start on boot
  [4/4]: starting ntpd
Done configuring NTP daemon (ntpd).
Configuring directory server (dirsrv): Estimated time 1 minute
  [1/38]: creating directory server user
  [2/38]: creating directory server instance
<< stuck forever

Version-Release number of selected component (if applicable):
389-ds-base-1.3.1.4-1.el7.x86_64
ipa-server-3.2.2-1.el7.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Install ipa-server package
2. Run ipa-server-install
3.

Actual results:
Installation stucks in "creating directory server instance" step

Expected results:
Installation does not stuck

Additional info:
Attaching setup-ds.pl strace and ipaserver-install.log if that helps anything.
Comment 1 Martin Kosek 2013-07-22 12:30:23 EDT
Created attachment 776971 [details]
Strace of setup-ds.pl
Comment 2 Martin Kosek 2013-07-22 12:31:36 EDT
Created attachment 776972 [details]
IPA server install log
Comment 3 Martin Kosek 2013-07-22 12:34:06 EDT
Ah, I see the setup-ds.pl finished after all, it just took very long time (8 minutes in my case) - lowering severity.
Comment 4 Rich Megginson 2013-07-22 12:35:03 EDT
Can you run setup-ds.pl with the -ddd option to get debugging output?  It looks like it is having trouble with semanage.
Comment 5 Martin Kosek 2013-07-22 12:35:40 EDT
Created attachment 776973 [details]
Successful, but very long run of setup-ds.pl
Comment 7 Nathan Kinder 2013-07-22 16:15:30 EDT
I'm pretty sure that this is related to semanage being broken by the recent build of policycoreutils-python (see bug 980143).  Specifically, semanage in policycoreutils-2.1.14-66.el7 thinks that the options used by setup-ds.pl are incorrect.

What version of policycoreutils-python are you using?  Does 'semanage port -l' work properly, or does it complain about illegal usage?
Comment 8 Rich Megginson 2013-07-22 16:33:44 EDT
(In reply to Nathan Kinder from comment #7)
> I'm pretty sure that this is related to semanage being broken by the recent
> build of policycoreutils-python (see bug 980143).  Specifically, semanage in
> policycoreutils-2.1.14-66.el7 thinks that the options used by setup-ds.pl
> are incorrect.
> 
> What version of policycoreutils-python are you using?  Does 'semanage port
> -l' work properly, or does it complain about illegal usage?

In the strace output it looks as though semanage is complaining, so yes, it looks like this is the problem.
Comment 9 Martin Kosek 2013-07-23 02:57:57 EDT
(In reply to Nathan Kinder from comment #7)
> I'm pretty sure that this is related to semanage being broken by the recent
> build of policycoreutils-python (see bug 980143).  Specifically, semanage in
> policycoreutils-2.1.14-66.el7 thinks that the options used by setup-ds.pl
> are incorrect.
> 
> What version of policycoreutils-python are you using?  Does 'semanage port
> -l' work properly, or does it complain about illegal usage?

I used policycoreutils-2.1.14-66.el7.x86_64, 'semanage port -l' indeed reported illegal use:

# semanage port -l
list option can not be used with --range

When I updated to policycoreutils-2.1.14-67.el7.x86_64, problem with setup-ds.pl went away. Thanks for help Nathan and Rich! Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.