This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 987100 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: beakerlib (Show other bugs)
19
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Petr Muller
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 13:34 EDT by Karel Srot
Modified: 2016-09-19 22:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:16:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2013-07-22 13:34:49 EDT
Description of problem:

I am unable to execute tests on F-19/ppc64 because of the following error:

test -x runtest.sh || chmod a+x runtest.sh
./runtest.sh
Traceback (most recent call last):
  File "/usr/bin/beakerlib-journalling", line 717, in <module>
    sys.exit(main())
  File "/usr/bin/beakerlib-journalling", line 655, in main
    return Journal.initializeJournal(options.test, options.package)
  File "/usr/bin/beakerlib-journalling", line 418, in initializeJournal
    return Journal.saveJournal(newdoc)
  File "/usr/bin/beakerlib-journalling", line 426, in saveJournal
    output.write(newdoc.toxml().encode('utf-8'))
  File "/usr/lib64/python2.7/xml/dom/minidom.py", line 46, in toxml
    return self.toprettyxml("", "", encoding)
  File "/usr/lib64/python2.7/xml/dom/minidom.py", line 61, in toprettyxml
    return writer.getvalue()
  File "/usr/lib64/python2.7/StringIO.py", line 271, in getvalue
    self.buf += ''.join(self.buflist)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 23: ordinal not in range(128)
rlJournalStart: Failed to initialize the journal. Bailing out...
make: *** [run] Error 1

Version-Release number of selected component (if applicable):
probably
beakerlib-redhat-1-6.fc16.noarch

How reproducible:
always
I have scheduled a job in beaker on F-19 / ppc64
Comment 1 Petr Muller 2013-07-23 08:29:28 EDT
What is the 'beakerlib' package version? We had such bug in F19 gold which was fixed later in an update. If the box in question was not updated, but simply installed from GOLD tree, then it's probably that one.
Comment 2 Karel Srot 2013-07-23 08:41:32 EDT
should be beakerlib-1.7-1.fc19.noarch.
Comment 3 Petr Muller 2013-07-23 11:16:19 EDT
Yep, that's it. That is already fixed in sufficiently updated F19. See bug 961121.

*** This bug has been marked as a duplicate of bug 961121 ***
Comment 4 Karel Srot 2013-07-24 01:49:59 EDT
Yes, I can confirm that the bug is fixed in recent beakerlib versions (I tried 1.8-1.fc19). OTOH for some reason the latest version available in F19 ppc64 is 1.7-1.fc19. Any idea why?
Comment 5 Petr Muller 2013-07-26 03:39:58 EDT
Good point. Maybe I need to do something more to update also on ppc. I'll research on that and let you know here.

Note You need to log in before you can comment on or make changes to this bug.