Bug 987208 - Document added iowait-is-busy-time sysfs tunable
Document added iowait-is-busy-time sysfs tunable
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Performance_Tuning_Guide (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Russell Dickenson
ecs-bugs
: Documentation
Depends On: 608432
Blocks: 846704
  Show dependency treegraph
 
Reported: 2013-07-22 20:47 EDT by Laura Bailey
Modified: 2016-05-17 07:14 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 608432
Environment:
Last Closed: 2016-05-17 07:11:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Eric Sandeen 2013-08-08 12:45:25 EDT
This is not a new tunable, it's been in the kernel since the earliest RHEL6 releases.

That being said, I'm not an expert on it.  It went in for Bug 585330 - ["RHEL6] Fix performance issue with ondemand governor" over 3 years ago.  Rik van Riel owned that bug.

Well, anyway, to the best of my understanding it makes IO count as "CPU busy" so that the cpu doesn't go into a power saving state while IO is happening, thus keeping IO perf from dropping.
Comment 5 Eric Sandeen 2013-08-26 13:02:49 EDT
This patch added the tunable and offers a brief description of what it does.

http://patchwork.usersys.redhat.com/patch/25156/
Comment 8 Laura Bailey 2014-07-11 00:47:01 EDT
Note that the 6.6 flag has been removed because this bug can be completed asynchronously, not because it is nacked for the 6.6 timeframe.
Comment 28 Milan Navratil 2016-05-17 07:11:10 EDT
The update is available on the Customer Portal:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Performance_Tuning_Guide/index.html#s-cpu-cpufreq

Closing the BZ.

Note You need to log in before you can comment on or make changes to this bug.