Bug 987211 - [glossary-push] Show the error message "transLang must be specified" when -Dzanata.transLang is missing
[glossary-push] Show the error message "transLang must be specified" when -Dz...
Status: CLOSED DUPLICATE of bug 1193297
Product: Zanata
Classification: Community
Component: Component-Maven (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Damian Jansen
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 21:42 EDT by Ding-Yi Chen
Modified: 2015-02-17 01:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 01:15:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-07-22 21:42:31 EDT
Description of problem:
When pushing glossary without specifing translation languages,

Following message is shown:
[ERROR] Failed to execute goal org.zanata:zanata-maven-plugin:3.0.1-SNAPSHOT:glossary-push (default-cli) on project null: Zanata mojo exception: localeId -> [Help 1]

It will be more informative to say that transLang must be specified.

Version-Release number of selected component (if applicable):
Server Zanata version 3.0.0-alpha-2-SNAPSHOT (20130723-0033)
Client 3.0.1-SNAPSHOT (commit 4ad67d7066)

How reproducible:
Always

Steps to Reproduce:
1. mvn zanata:glossary-push -Dzanata.glossaryFile=compendium-zh_TW.po -Dzanata.url=<zanataServer>

Actual results:
[ERROR] Failed to execute goal org.zanata:zanata-maven-plugin:3.0.1-SNAPSHOT:glossary-push (default-cli) on project null: Zanata mojo exception: localeId -> [Help 1]


Expected results:
[ERROR] Failed to execute goal org.zanata:zanata-maven-plugin:3.0.1-SNAPSHOT:glossary-push (default-cli) on project null: Zanata mojo exception: transLang must be specified  -> [Help 1]


Additional info:
Comment 1 Ding-Yi Chen 2015-02-17 01:15:01 EST
The behavior seems to change to Bug 1193297

*** This bug has been marked as a duplicate of bug 1193297 ***

Note You need to log in before you can comment on or make changes to this bug.