Bug 987264 - unmatched information show when adding 10gen-mms-agent-0.1 to the app with mongodb embedded
unmatched information show when adding 10gen-mms-agent-0.1 to the app with mo...
Status: CLOSED DUPLICATE of bug 987872
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 02:15 EDT by Yan Du
Modified: 2015-05-14 19:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 10:55:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Du 2013-07-23 02:15:38 EDT
Description of problem:

unmatched information show when adding 10gen-mms-agent-0.1 to an app without deploying settings.py(mongodb have embedded)

[root@Daphne test]# rhc cartridge add 10gen-mms-agent-0.1 -a py1
Adding 10gen-mms-agent-0.1 to application 'py1' ... Cartridge '10gen-mms-agent-0.1' can not be added with out cartridge '10gen-mms-agent'.


Version-Release number of selected component (if applicable):
devenv-3540
rhc-1.12.1


How reproducible:
Always


Steps to Reproduce:
1. create a python app
   rhc app create py1 python-2.6
2. add mongodb 
   rhc cartridge add -a py1 -c mongodb-2.2
3. add 10gen-mms-agent-0.1 to the app without deploying settings.py
   rhc cartridge add 10gen-mms-agent-0.1 -a py1


Actual results:
Adding 10gen-mms-agent-0.1 to application 'py1' ... Cartridge '10gen-mms-agent-0.1' can not be added with out cartridge '10gen-mms-agent'.


Expected results:
should inform user that 10gen-mms-agent-0.1 can be added successfully after deploy settings.py to the app
Comment 1 Yan Du 2013-07-24 06:04:54 EDT
test on devenv_3545

10gen-mms-agent-0.1 totally cannot be added to app, even deploy settings to the app

steps:
1. rhc app create py1 python-2.6 mongodb-2.2
2. deploy settings in repo and git push
3. rhc cartridge add -a py1 -c 10gen-mms-agent-0.1

[root@Daphne test]# rhc cartridge add -a py1 -c 10gen-mms-agent-0.1
Adding 10gen-mms-agent-0.1 to application 'py1' ... Cartridge '10gen-mms-agent-0.1' can not be added with out cartridge '10gen-mms-agent'.
Comment 2 Jhon Honce 2013-07-24 10:55:37 EDT

*** This bug has been marked as a duplicate of bug 987872 ***

Note You need to log in before you can comment on or make changes to this bug.