Bug 987277 - Installer can't automatically detect appropriate storage device for RHEL 6.4 x64 automated installation in UEFI mode
Installer can't automatically detect appropriate storage device for RHEL 6.4 ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.4
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 02:59 EDT by Jack Zhou
Modified: 2013-07-31 14:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 14:22:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file for RHEL 6.4 x64 installation in UEFI mode (4.25 KB, text/plain)
2013-07-23 02:59 EDT, Jack Zhou
no flags Details
screenshot for installation failed (29.76 KB, image/jpeg)
2013-07-23 03:04 EDT, Jack Zhou
no flags Details

  None (edit)
Description Jack Zhou 2013-07-23 02:59:10 EDT
Created attachment 777185 [details]
kickstart file for RHEL 6.4 x64 installation in UEFI mode

Description of problem:
  When multiple storage devices exist in system that support UEFI, sometimes RHEL 6.4 x64 installer can't automatically detect appropriate storage device to execute installation under UEFI mode.
  In my system, there are two storage devices, one is 500GB, another is 36MB. I use kickstart file(refer to attachment) to execute automated installation. In the kickstart file, two commands use dev name "sda":

bootloader --location=partition --driveorder=sda --append="crashkernel=auto rhgb quiet"
......
clearpart --all --drives=sda

  Sometimes the installation succeed because I find that the 500GB device is named "/dev/sda" and the 36MB device is named "/dev/sdb" via console Ctrl+Alt+F2. But sometimes the installation failed because the 36MB device is named "/dev/sda" and the 500GB device is named "/dev/sdb". The message shows "Could not find enough free space for automatic partitioning"(refer to attachment).
  I remove "--drives=sda" from clearpart command in kickstart file. The symptom
still exist. sometimes installation succeed, sometimes failed.
  I remove "--drives=sda" and "--driveorder=sda", the installation failed. It shows "Could not create partition /boot/efi".
  I don't know how the installer detect storage devices. How to let installer automatically select appropriate storage device for installation via kickstart?

 

Version-Release number of selected component (if applicable):
anaconda for RHEL 6.4 x64


How reproducible:
Always

Steps to Reproduce:
1. Prepare multiple storage devices on your system. Some devices are too small and can't be used for OS installation. Some devices are large and can be used for OS installation. 
2. Use the specific kickstart file to install RHEL 6.4 x64 repeatedly.

Actual results:
  Sometimes installation succeed, sometimes faild.

Expected results:
  Installer automatically select appropriate storage device via kickstart file and the installation always succeed.


Additional info:
Comment 2 Jack Zhou 2013-07-23 03:04:07 EDT
Created attachment 777186 [details]
screenshot for installation failed
Comment 3 David Cantrell 2013-07-31 14:22:25 EDT
Names like sda and sdb are not guaranteed.  Use /dev/disk/by-path for stable names.  You can use these in your kickstart file, as explained in the Migration Planning Guide for RHEL-6:

https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Migration_Planning_Guide/sect-Migration_Guide-Installation-Graphical_Installer-Kickstart.html

You can also use /dev/disk/by-id names.

While Red Hat welcomes bug reports on Red Hat products here in our public bugzilla database, please keep in mind that bugzilla is not a support tool or means of accessing support.  If you would like technical support please visit our support portal at access.redhat.com or call us for information on subscription offerings to suit your needs.

Note You need to log in before you can comment on or make changes to this bug.