Bug 987284 - How to check ACPI5.0 function in Redhat6.4. [NEEDINFO]
How to check ACPI5.0 function in Redhat6.4.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 03:24 EDT by matthew
Modified: 2015-11-16 15:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 15:44:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jmcnicol: needinfo? (Matthew.Lin)


Attachments (Terms of Use)

  None (edit)
Description matthew 2013-07-23 03:24:18 EDT
Description of problem:
When system enters to Redhat6.4, how can we check ACPI5.0 function? 
By command? or any tools can check it?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2013-10-13 19:21:42 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Jaroslav Škarvada 2014-10-24 06:10:42 EDT
Acpid is a daemon that dispatches ACPI events to user-space programs. It doesn't query (and it wasn't designed to) ACPI about any other information (like AC/BAT status, temperatures, charge status, interface version, etc.).

Currently I am not sure whether it is possible to get the ACPI version from the kernel, thus reassigning to kernel. If yes, this functionality could be added to some other tool like acpitool (which is currently not in RHEL).
Comment 4 Jeremy McNicoll 2015-11-11 18:57:30 EST
Take a look at 

https://acpica.org/downloads

You will need to compile from source.  This will allow you to extract the info needed. 

BTW- ACPI version is embedded in the tables.  These tables are provided by the BIOS.   ie) EFI

Note You need to log in before you can comment on or make changes to this bug.