Bug 987317 - [fork][origin_broker_25]should not update domain name via 'id' since 'id' field is already changed to 'name' for rest api version 1.6
[fork][origin_broker_25]should not update domain name via 'id' since 'id' f...
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Master (Show other bugs)
2.x
All All
medium Severity medium
: ---
: ---
Assigned To: Lili Nader
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 04:56 EDT by zhaozhanqi
Modified: 2015-05-14 20:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 17:01:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhaozhanqi 2013-07-23 04:56:11 EDT
Description of problem:
Since we have change 'id' to 'name' about domain resource, now we invoke rest api version=1.6 to update domain name use 'id': curl -k -H 'Accept: application/xml,version=1.6' --user user:pass https://<instance>/broker/rest/domains/zqd -d id=newzqd -X PUT, it still can be updated successfully.

Version-Release number of selected component (if applicable):
fork_ami_online_broker_25_703

How reproducible:
always

Steps to Reproduce:
1. create one domain use rest api
  
2. update domain user rest api version=1.6
   curl -k -H 'Accept: application/xml,version=1.6' --user user:pass https://<instance>/broker/rest/domains/zqd -d id=newzqd -X PUT
3.

Actual results:
domain name will be updated 

Expected results:

should not be updated 
should be showed like 'Name is required'

Additional info:
if creating domain use 'id' for rest api version 1.6,the result is our expected,will be failed.

<severity>error</severity>
      <text>Name is required and cannot be blank.</text>
      <exit-code>106</exit-code>
Comment 1 Lili Nader 2013-07-25 17:01:51 EDT
Since we still have to support clients that use version 1.5 or earlier AND the routing in rails has to support ids.  This cannot be fixed at this time.

Note You need to log in before you can comment on or make changes to this bug.