Bug 987361 - Overwrite of default path definition not possible as described
Overwrite of default path definition not possible as described
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high
: GA
: EAP 6.3.0
Assigned To: sgilda
Petr Kremensky
: Documentation
: 1089150 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 06:10 EDT by wfink
Modified: 2014-09-29 14:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.11 Build Name: 11865, Administration and Configuration Guide-6.1-4 Build Date: 12-07-2013 01:29:20 Topic ID: 5044-458669 [Specified]
Last Closed: 2014-08-06 10:36:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wfink 2013-07-23 06:10:12 EDT
Title: Filesystem Paths

The path variables can not be overwritten as shown in the doc:
"Users can add their own paths or override all except the first five of the above..."

In standalone mode the only possibility is to add it as env.variable at start with the "-Djboss....=" parameter.
For domain mode I try to use it as path or system-property (boot-time) with no success.
It need to be clarified how it can be achieved.


reference community thread: https://community.jboss.org/thread/230412


The messages are:
[domain@localhost:9999 /] /host=master/server-config=server-one/path=jboss.server.log.dir:add(path="test/server-one", relative-to="jboss.domain.server.dir")   
{
    "outcome" => "failed",
    "result" => undefined,
    "failure-description" => "JBAS010839: Operation failed or was rolled back on all servers.",
    "rolled-back" => true,
    "server-groups" => {"main-server-group" => {"host" => {"master" => {"server-one" => {"response" => {
        "outcome" => "failed",
        "failure-description" => "JBAS014803: Duplicate resource [(\"path\" => \"jboss.server.log.dir\")]",
        "rolled-back" => true
    }}}}}}
}

[domain@localhost:9999 /] /host=master/server-config=server-one/system-property=jboss.server.log.dir:add(boot-time=true, value="${jboss.domain.server.dir}/test/server-one")
{
    "outcome" => "failed",
    "result" => undefined,
    "failure-description" => "JBAS010839: Operation failed or was rolled back on all servers.",
    "rolled-back" => true,
    "server-groups" => {"main-server-group" => {"host" => {"master" => {"server-one" => {"response" => {
        "outcome" => "failed",
        "failure-description" => "JBAS015845: System property jboss.server.log.dir cannot be set via the xml configuration file or from a management client; it's value must be known at initial process start so it can only set from the commmand line",
        "rolled-back" => true
    }}}}}}
}
Comment 1 sgilda 2014-06-05 14:32:38 EDT
Lucas, let me know if you need help with this one.
Comment 8 David Michael 2014-07-16 02:32:27 EDT
*** Bug 1089150 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.