Bug 987428 - mark dht_linkfile creation/deletion fop's as internal
mark dht_linkfile creation/deletion fop's as internal
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
:
Depends On:
Blocks: 987432
  Show dependency treegraph
 
Reported: 2013-07-23 07:24 EDT by shishir gowda
Modified: 2016-02-17 19:19 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 987432 (view as bug list)
Environment:
Last Closed: 2014-04-17 07:44:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shishir gowda 2013-07-23 07:24:29 EDT
Description of problem:

Currently dht creates/deletes linkfiles for various ops like
rename/linking and when layout changes. dht_linkfile_create
already sends a key GLUSTERFS_INTERNAL_FOP_KEY in dict to
identify this as an internal fop and not user based op.

Enhancing rename related links/unlinks to send this key too.
Marker/changelog or other xlators can now identify these as
internal fops and handle them accordingly

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2013-07-23 07:27:28 EDT
REVIEW: http://review.gluster.org/5335 (cluster/dht: mark linkfile creation/deletion as internal fop) posted (#2) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 2 Anand Avati 2013-07-24 07:28:10 EDT
COMMIT: http://review.gluster.org/5335 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit ab87748907b3312aaa751231a2e47b2efcf92b10
Author: shishir gowda <sgowda@redhat.com>
Date:   Wed Jul 17 12:10:24 2013 +0530

    cluster/dht: mark linkfile creation/deletion as internal fop
    
    Currently dht creates/deletes linkfiles for various ops like
    rename/linking and when layout changes. dht_linkfile_create
    already sends a key GLUSTERFS_INTERNAL_FOP_KEY in dict to
    identify this as an internal fop and not user based op.
    
    Enhancing rename related links/unlinks to send this key too.
    Marker/changelog or other xlators can now identify these as
    internal fops and handle them accordingly
    
    Change-Id: Ib1ca789e6dbce48703c55ad3f4f88f7cd2df3d06
    BUG: 987428
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5335
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 5 Niels de Vos 2014-04-17 07:44:04 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.