Bug 987480 - Execution exceptions thrown in org.infinispan.distexec when TimeoutException is expected (random test failure)
Execution exceptions thrown in org.infinispan.distexec when TimeoutException ...
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Paul Ferraro
Infinispan testsuite
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 09:06 EDT by Richard Janík
Modified: 2014-05-21 09:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 02:27:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Janík 2013-07-23 09:06:25 EDT
Description of problem:

EAP 6.1.1.ER3
Infinispan 5.2.7

Four tests get ExecutionExceptions (randomly...) when expecting TimeoutExceptions:
DistributedExecutorWithCacheLoaderTest
DistributedExecutorNonConcurrentTest
ReplSyncDistributedExecutorWithTopologyAwareNodesTest
ReplSyncDistributedExecutorTest

A TimeoutException is wrapped inside the ExecutionException -> ExecutionException(caused by CacheExeption(caused by TimeoutException))

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-Infinispan/job/eap-6x-infinispan-hpux-matrix-clone/3/BITS=-d64,jdk=jdk16_hpux,label=hpux11v3/testReport/org.infinispan.distexec/DistributedExecutorWithCacheLoaderTest/testBasicTargetRemoteDistributedCallableWithHighFutureAndLowTaskTimeout/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-Infinispan/job/eap-6x-infinispan-hpux-matrix-clone/3/BITS=-d64,jdk=jdk17_hpux,label=hpux11v3/testReport/org.infinispan.distexec/DistributedExecutorNonConcurrentTest/testBasicTargetRemoteDistributedCallableWithHighFutureAndLowTaskTimeout/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-Infinispan/job/eap-6x-infinispan-hpux-matrix-clone/3/BITS=-d64,jdk=jdk17_hpux,label=hpux11v3/testReport/org.infinispan.distexec/ReplSyncDistributedExecutorWithTopologyAwareNodesTest/testBasicTargetRemoteDistributedCallableWithHighFutureAndLowTaskTimeout/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-Infinispan/job/eap-6x-infinispan-solaris-matrix/38/jdk=java17_default,label=sol10_sparc64/testReport/org.infinispan.distexec/ReplSyncDistributedExecutorTest/testBasicTargetRemoteDistributedCallableWithHighFutureAndLowTaskTimeout/
Comment 2 Paul Ferraro 2014-05-21 09:30:31 EDT
These issues are specific to the Infinispan testsuite, and either reside in modules that are not used in EAP, or pertain to use cases that are not supported in EAP.  Setting resolution to WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.