Bug 987523 - firewall-cmd --add-rich-rule with source and destination combination
firewall-cmd --add-rich-rule with source and destination combination
Status: CLOSED DUPLICATE of bug 979804
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 10:53 EDT by Petr Sklenar
Modified: 2013-07-23 11:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 11:08:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-07-23 10:53:14 EDT
Description of problem:
firewall-cmd --add-rich-rule with  source and destination combination

Version-Release number of selected component (if applicable):
firewalld-0.3.3-2.fc19.noarch

How reproducible:
always

Steps to Reproduce:
1,
[root@masox ~]# firewall-cmd --add-rich-rule='rule family="ipv4" source address="10.34.4.76" destination address="10.11.5.7" protocol value=icmp reject'
Error: global name 'msg' is not defined
2,
[root@masox ~]# echo $?
254
3,
[root@masox ~]# tail /var/log/messages -n2
Jul 23 16:27:14 masox firewalld: 2013-07-23 16:27:14 ERROR: '/sbin/iptables -t filter -A IN_ZONE_work_deny -s 10.34.4.76 -s 10.11.5.7 -p icmp -m conntrack --ctstate NEW -j REJECT' failed: iptables v1.4.18: multiple -s flags not allowed
Jul 23 16:27:14 masox firewalld: 2013-07-23 16:27:14 ERROR: '/sbin/iptables -t filter -A IN_ZONE_work_deny -s 10.34.4.76 -s 10.11.5.7 -p icmp -m conntrack --ctstate NEW -j REJECT' failed: iptables v1.4.18: multiple -s flags not allowed


Actual results:
Error: global name 'msg' is not defined

Expected results:
that's probably wrong command combination but error message is complete out of scope

Additional info:
Comment 1 Thomas Woerner 2013-07-23 11:08:13 EDT

*** This bug has been marked as a duplicate of bug 979804 ***

Note You need to log in before you can comment on or make changes to this bug.