Bug 987596 - add functions to get size/position of a component
add functions to get size/position of a component
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: newt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 14:25 EDT by Dan Winship
Modified: 2013-08-06 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 12:31:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (1.37 KB, patch)
2013-07-23 14:25 EDT, Dan Winship
no flags Details | Diff

  None (edit)
Description Dan Winship 2013-07-23 14:25:42 EDT
Created attachment 777426 [details]
patch

I want to have some pop-up menus in my newt-based UI. A listbox in its own window works great; the only problem is figuring out where to put it (since everything else is getting laid out via a grid).

This patch adds newtComponentGetSize() and newtComponentGetPosition(), to peek at the corresponding internal fields, so I can see where the grid put my components, and then position the menu accordingly.
Comment 1 Miroslav Lichvar 2013-07-31 07:03:04 EDT
Thanks for the patch. It's pushed to the newt git.
Comment 2 Miroslav Lichvar 2013-08-06 12:31:56 EDT
This is in newt-0.52.16-1.fc20.

Note You need to log in before you can comment on or make changes to this bug.