Bug 987597 - SELinux is preventing systemd-tmpfile from 'create' accesses on the chr_file vhost-net.
SELinux is preventing systemd-tmpfile from 'create' accesses on the chr_file ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:cd7d166d91dd9548376fef88e8b...
:
: 987598 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 14:38 EDT by Nicolas Mailhot
Modified: 2013-07-24 18:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 18:22:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-07-23 14:38:32 EDT
Description of problem:
SELinux is preventing systemd-tmpfile from 'create' accesses on the chr_file vhost-net.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que systemd-tmpfile devrait être autorisé à accéder create sur vhost-net chr_file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep systemd-tmpfile /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_tmpfiles_t:s0
Target Context                system_u:object_r:vhost_device_t:s0
Target Objects                vhost-net [ chr_file ]
Source                        systemd-tmpfile
Source Path                   systemd-tmpfile
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.0-0.rc2.git1.1.fc20.x86_64 #1
                              SMP Tue Jul 23 14:24:16 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-23 20:26:28 CEST
Last Seen                     2013-07-23 20:26:28 CEST
Local ID                      9288801b-0d0b-4275-a14d-573c7e322b68

Raw Audit Messages
type=AVC msg=audit(1374603988.541:23): avc:  denied  { create } for  pid=570 comm="systemd-tmpfile" name="vhost-net" scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:vhost_device_t:s0 tclass=chr_file


Hash: systemd-tmpfile,systemd_tmpfiles_t,vhost_device_t,chr_file,create

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.11.0-0.rc0.git3.1.fc20.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-07-24 18:22:38 EDT
Fixed in selinux-policy-3.12.1-67.fc20.noarch
Comment 2 Daniel Walsh 2013-07-24 18:23:21 EDT
*** Bug 987598 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.