Bug 987602 - SELinux is preventing systemd-tmpfile from 'getattr' accesses on the chr_file /dev/btrfs-control.
SELinux is preventing systemd-tmpfile from 'getattr' accesses on the chr_file...
Status: CLOSED DUPLICATE of bug 987599
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:37701d00f5c88556d8e2a39d314...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 14:39 EDT by Nicolas Mailhot
Modified: 2013-07-24 04:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 04:33:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-07-23 14:39:46 EDT
Description of problem:
SELinux is preventing systemd-tmpfile from 'getattr' accesses on the chr_file /dev/btrfs-control.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que systemd-tmpfile devrait être autorisé à accéder getattr sur btrfs-control chr_file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep systemd-tmpfile /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_tmpfiles_t:s0
Target Context                system_u:object_r:lvm_control_t:s0
Target Objects                /dev/btrfs-control [ chr_file ]
Source                        systemd-tmpfile
Source Path                   systemd-tmpfile
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.11.0-0.rc0.git3.1.fc20.x86_64 #1
                              SMP Tue Jul 9 21:34:37 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-23 20:34:45 CEST
Last Seen                     2013-07-23 20:34:45 CEST
Local ID                      17154912-6939-4c5c-94c6-efd6f8ecf0e8

Raw Audit Messages
type=AVC msg=audit(1374604485.340:63): avc:  denied  { getattr } for  pid=574 comm="systemd-tmpfile" path="/dev/btrfs-control" dev="devtmpfs" ino=9970 scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:lvm_control_t:s0 tclass=chr_file


Hash: systemd-tmpfile,systemd_tmpfiles_t,lvm_control_t,chr_file,getattr

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.11.0-0.rc0.git3.1.fc20.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-24 04:33:32 EDT

*** This bug has been marked as a duplicate of bug 987599 ***

Note You need to log in before you can comment on or make changes to this bug.