Bug 987625 - AttributeError: 'NoneType' object has no attribute 'format'
AttributeError: 'NoneType' object has no attribute 'format'
Status: CLOSED DUPLICATE of bug 827274
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:8d5e61758ab83bc65d1896ace2e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 15:08 EDT by Renato
Modified: 2013-07-24 10:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 10:37:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Renato 2013-07-23 15:08:28 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-bynmkU
hashmarkername: anaconda
kernel:         3.3.4-5.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Ter 23 Jul 2013 13:22:23 BRT
version:        17

anaconda-tb-bynmkU: Binary file, 1310146 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.29 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 953, in mirrorFailureCB
:    dev.format.mountpoint = self.tree
:  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 298, in _failure
:    action = cb(cb_obj, *args, **kwargs) or {}
:  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 403, in _mirror_try
:    self._failure(gr, obj)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 409, in urlgrab
:    return self._mirror_try(func, url, kw)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 843, in _getFile
:    size=size
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1619, in _retrieveMD
:    size=thisdata.size)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 175, in populate
:    db_fn = repo._retrieveMD(mydbtype)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 294, in populateSack
:    sack.populate(repo, mdtype, callback, cacheonly)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 767, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 730, in doSackSetup
:    return self._getSacks(archlist=archlist, thisrepo=thisrepo)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1303, in <lambda>
:    self.__withFuncDo(anaconda, lambda r: self.ayum.doSackSetup(thisrepo=r.id),
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1328, in __withFuncDo
:    fn(repo)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1305, in doSackSetup
:    callback=SackSetupProgress(anaconda.intf))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1269, in doBackendSetup
:    self.doSackSetup(anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/backend.py", line 192, in doBackendSetup
:    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/text.py", line 507, in run
:    self.anaconda.dispatch.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 326, in run
:    self.anaconda.intf.run(self.anaconda)
:  File "/usr/sbin/anaconda", line 863, in <module>
:    anaconda.dispatch.run()
:AttributeError: 'NoneType' object has no attribute 'format'

environ:
:LANG=pt_BR.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:PWD=/
:LIBUSER_CONF=/tmp/libuser.oEkwV6
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:MALLOC_PERTURB_=204
:TZ=America/Sao_Paulo
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
Comment 1 David Shea 2013-07-24 10:37:41 EDT

*** This bug has been marked as a duplicate of bug 827274 ***

Note You need to log in before you can comment on or make changes to this bug.