Bug 987668 - Dist-geo-rep: geo-rep start and stop force always succeeds even without geo-rep create
Dist-geo-rep: geo-rep start and stop force always succeeds even without geo-r...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Avra Sengupta
M S Vishwanath Bhat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 16:31 EDT by M S Vishwanath Bhat
Modified: 2016-05-31 21:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.19rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M S Vishwanath Bhat 2013-07-23 16:31:11 EDT
Description of problem:
geo-rep start and stop fails without create. But even without session being created and with force option both start and stop force succeeds.

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.12rhs.beta5-2.el6rhs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a master and slave volume.
2. Run geo-rep start force
3. Run geo-rep stop force

Actual results:

[root@spitfire]# gluster v geo hosa-master falcon::hosa-slave start 
Session between hosa-master and falcon::hosa-slave has not been created. Please create session and retry.
geo-replication command failed

[root@spitfire]# gluster v geo hosa-master falcon::hosa-slave start force
Starting geo-replication session between hosa-master & falcon::hosa-slave has been successful


[root@spitfire]# gluster v geo hosa-master falcon::hosa-slave stop
geo-replication session b/w hosa-master & falcon::hosa-slave is not running on this node.
geo-replication command failed


[root@spitfire]# gluster v geo hosa-master falcon::hosa-slave stop force
Stopping geo-replication session between hosa-master & falcon::hosa-slave has been successful


start and stop force succeeds even for the non-existant slave volume.

Expected results:
stop and start force should return failure when the session is not created yet or if the slave volume is not present or not started.

Additional info:
Comment 2 Avra Sengupta 2013-08-07 10:07:40 EDT
geo-rep stop force is a afail safe method and will always succeed. The geo-rep start force fix is in the patch https://code.engineering.redhat.com/gerrit/11204
Comment 3 Sayan Saha 2013-08-12 20:01:20 EDT
I think it would be great if we can provide a proper error message when both start and stop force commands are executed while a corresponding geo-rep session does not exist. Looks like the issue with start force is addressed but stop force is not. Reducing the priority to medium as this should not have a big end-user impact.
Comment 4 M S Vishwanath Bhat 2013-08-19 06:03:02 EDT
The issue is fixed now. I can't start a session with a invalid slave volume or a slave node which is not reachable.


Tested in version:

[root@spitfire ~]# rpm -q glusterfs
glusterfs-3.4.0.20rhs-2.el6rhs.x86_64

[root@spitfire ~]# gluster --version
glusterfs 3.4.0.20rhs built on Aug 14 2013 09:04:38
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.



[root@spitfire ~]# gluster v geo master falcon1::slave start
falcon1 not reachable.
geo-replication command failed

[root@spitfire ~]# gluster v geo master falcon1::slave start force
falcon1 not reachable.
geo-replication command failed

[root@spitfire ~]# gluster v geo master falcon::slaveg start
Session between master and falcon::slaveg has not been created. Please create session and retry.
geo-replication command failed

[root@spitfire ~]# gluster v geo master falcon::slaveg start force
Session between master and falcon::slaveg has not been created. Please create session and retry.
geo-replication command failed

[root@spitfire ~]# gluster v geo master falcon::slave1 start
Session between master and falcon::slave1 has not been created. Please create session and retry.
geo-replication command failed

[root@spitfire ~]# gluster v geo master falcon::slave1 start force
Session between master and falcon::slave1 has not been created. Please create session and retry.
geo-replication command failed



[root@spitfire ~]# gluster v geo master falcon::slave status
NODE                       MASTER    SLAVE            HEALTH    UPTIME         
---------------------------------------------------------------------------
spitfire.blr.redhat.com    master    falcon::slave    Stable    00:01:14       
harrier.blr.redhat.com     master    falcon::slave    Stable    00:01:14       
mustang.blr.redhat.com     master    falcon::slave    Stable    00:01:14       
typhoon.blr.redhat.com     master    falcon::slave    Stable    00:01:13       


[root@spitfire ~]# gluster v geo master falcon::slave1 stop
Geo-replication session between master and falcon::slave1 does not exist.
geo-replication command failed


[root@spitfire ~]# gluster v geo master falcon::slave1 stop force
Stopping geo-replication session between master & falcon::slave1 has been successful


[root@spitfire ~]# gluster v geo master falcon1::slave stop force
falcon1 not reachable.
geo-replication command failed


[root@spitfire ~]# gluster v geo master falcon::slave stop
Stopping geo-replication session between master & falcon::slave has been successful


[root@spitfire ~]# gluster v geo master falcon::slave status
NODE                       MASTER    SLAVE            HEALTH     UPTIME       
--------------------------------------------------------------------------
spitfire.blr.redhat.com    master    falcon::slave    Stopped    N/A          
mustang.blr.redhat.com     master    falcon::slave    Stopped    N/A          
harrier.blr.redhat.com     master    falcon::slave    Stopped    N/A          
typhoon.blr.redhat.com     master    falcon::slave    Stopped    N/A          

Moving the bug to verified.
Comment 5 Scott Haines 2013-09-23 18:38:46 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:41:29 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.