Bug 987671 - Setup is in endless loop during all in one if host is none operational.
Setup is in endless loop during all in one if host is none operational.
Status: CLOSED WORKSFORME
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity low
: ---
: 3.3
Assigned To: Sandro Bonazzola
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 16:44 EDT by Ohad Basan
Modified: 2014-10-30 18:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 08:49:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ohad Basan 2013-07-23 16:44:55 EDT
Description of problem:
I had a problem during an all in one installation that failed and made the host non operational on the engine.
the setup is stuck on on an endless loop keep waiting for the host to become active.

[ INFO  ] Still waiting for VDSM host to become operational...
[ INFO  ] Still waiting for VDSM host to become operational...
[ INFO  ] Still waiting for VDSM host to become operational...
[ INFO  ] Still waiting for VDSM host to become operational...

I don't think it should fail if the host status in the engine is non operational.
Comment 1 Itamar Heim 2013-07-23 23:20:26 EDT
non-op == up in that regard, though worth a warning.
but what was the non-op reason?
Comment 2 Sandro Bonazzola 2013-07-25 09:59:31 EDT
Hi Ohad, it's not endless... It try to have the host up in 10 minutes. If host-deploy is not completed in 10 minutes it just log a warn without failing the setup.

The strange issue here is deploy taking so much.
Comment 3 Ohad Basan 2013-07-27 20:17:23 EDT
You are right.
it's not endless. it did fail after 10 minutes. although I still think host deploy should probe the engine for the host's status.
in this case it was non operational.
no point in keep trying
The reason that it wasn't up because the bridge wasn't created/
it was because of some dirt in my env though. I didn't see that reproducing
Comment 4 Sandro Bonazzola 2013-07-31 08:02:40 EDT
So this bug can be closed as works for me?

Note You need to log in before you can comment on or make changes to this bug.