Bug 987713 - [RFE] temp disable packagekit
[RFE] temp disable packagekit
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Icehouse
Assigned To: Martin Magr
Ami Jeain
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 20:19 EDT by Pádraig Brady
Modified: 2016-01-04 09:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 23:44:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pádraig Brady 2013-07-23 20:19:09 EDT
On RHEL 6.4 with gnome desktop installed, I got the following _sometimes_

ERROR : Error during puppet run : err: /Stage[main]/Horizon/Package[horizon]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-dashboard' returned 1: Existing lock /var/run/yum.pid: another copy is running as pid 7229.

Is there a way to temp disable packagekit during the install.
Maybe adjusting enabled in /etc/yum/pluginconf.d/refresh-packagekit.conf
around packstack runs might work?
Comment 1 Kashyap Chamarthy 2013-12-11 13:07:00 EST
Trying to triage RDO bugs, what's the status here? Does packstack maintainers think this is a reasonable change to be implemented?
Comment 2 Martin Magr 2014-01-15 07:06:11 EST
Interrupted yum happens sometimes, so lowering risk of that would be a good thing to do I guess.

And from my googling it should be easy change also:
http://ambari.apache.org/1.2.2/installing-hadoop-using-ambari/content/ambari-chap1-5-7.html
http://posix.in-egypt.net/content/howto-fedora-19-disabling-packagekit
http://www.databook.bz/?page_id=2864
Comment 3 Gilles Dubreuil 2014-03-18 23:44:24 EDT
A provisioned system is expected to be provided to Packstack not the other way around.

And because of the non production target nature of Packstack, this is not really a needed feature.

Also changing the refresh-packagekit.conf flag doesn't workaround another yum instance already launched in the background, pushing the problem further to kill that instance. Not sure we want Packstack on that road.

Note You need to log in before you can comment on or make changes to this bug.