This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 987726 - An error occurred executing 'gear postreceive' When push an app with submodule added
An error occurred executing 'gear postreceive' When push an app with submodul...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
: Rebase, ZStream
Depends On: 975183
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 22:19 EDT by Nan Wei
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version: rubygem-openshift-origin-node-1.9.14.1-1
Doc Type: Bug Fix
Doc Text:
The node runtime did not properly handle nested submodules, causing application builds to deploy improperly and produce an error. With this fix, logic was added to archive_git_submodules.sh in the node runtime to handle this case. Application deployments now work as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:20:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nan Wei 2013-07-23 22:19:36 EDT
Description of problem:
When creating a ruby app, git submodule add https://github.com/jhou1/submodule.git, then git push,  and prompting the following error:
Counting objects: 4, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (3/3), 371 bytes, done.
Total 3 (delta 1), reused 0 (delta 0)
remote: Stopping Ruby cart
remote: Waiting for stop to finish
remote: An error occurred executing 'gear postreceive'
remote: stdout: Initialized empty Git repository in /tmp/git_cache/.git/
remote: Submodule 'submodule' (https://github.com/jhou1/submodule.git) registered for path 'submodule'
remote: Initialized empty Git repository in /tmp/git_cache/submodule/.git/
remote: Submodule path 'submodule': checked out 'f34a7b53aeee72f1b10f0ed99751d4e04f5d9ce9'
remote: Submodule 'rack' (git://github.com/chneukirchen/rack.git) registered for path 'rack'
remote: Initialized empty Git repository in /tmp/git_cache/submodule/rack/.git/
remote: Submodule path 'rack': checked out '382c3c560f661df4fe9c1b31bb8d291721977949'
remote: Entering 'submodule'
remote: Entering 'submodule/rack'
remote: stderr: + pushd /tmp/
remote: + git clone /var/lib/openshift/51ee371ba421243308000169/git/ruby18.git git_cache
remote: + pushd git_cache
remote: + git submodule update --init --recursive
remote: + git submodule foreach --recursive 'git archive --format=tar HEAD | (cd /var/lib/openshift/51ee371ba421243308000169/app-root/runtime/repo/$name && tar --warning=no-timestamp -xf -)'
remote: /usr/libexec/git-core/git-submodule: line 283: cd: /var/lib/openshift/51ee371ba421243308000169/app-root/runtime/repo/rack: No such file or directory
remote: Stopping at 'rack'; script returned non-zero status.
remote: Stopping at 'submodule'; script returned non-zero status.
remote: 
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://51ee371ba421243308000169@ruby18-nweidomain.ose0722.com/~/git/ruby18.git/
   ff27e57..262e09f  master -> master
   
But if use devenv_3540, there is no such problem, it is pushed successfully.

Version-Release number of selected component (if applicable):
OpenShift Enterprise puddle: 1.2/2013-07-22.2

How reproducible:
always

Steps to Reproduce:
1. Create a ruby-1.8 application
#rhc app-create ruby18 ruby-1.8
2. Aftre creation, in app's repo, add submodule in setup
#git submodule add https://github.com/jhou1/submodule.git
3. git add && git commit && git push

Actual results:
The output of git push is as following:
remote: Stopping Ruby cart
remote: Waiting for stop to finish
remote: An error occurred executing 'gear postreceive'
remote: stdout: Initialized empty Git repository in /tmp/git_cache/.git/
remote: Submodule 'submodule' (https://github.com/jhou1/submodule.git) registered for path 'submodule'

Expected results:
App should be pushed successfully and no error should be occurred.

Additional info:
Comment 2 Brenton Leanhardt 2013-07-24 10:22:32 EDT
Upstream commit:

commit 1586aeb6db061e39d4d3835e6bc1834963805c69
Author: Jhon Honce <jhonce@redhat.com>
Date:   Tue Jun 18 16:43:13 2013 -0700

    Bug 975183 -  nested submodule repository cannot be found
    
    * lib/module001/module002 was not supported
    * test added
Comment 5 Johnny Liu 2013-07-26 10:11:10 EDT
Verified this bug with rubygem-openshift-origin-node-1.9.14.1-1.el6op.noarch, and PASS.
Comment 7 errata-xmlrpc 2013-08-05 13:20:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.